summaryrefslogtreecommitdiff
path: root/openwrt/package/elhttp
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/elhttp')
-rw-r--r--openwrt/package/elhttp/Config.in8
-rw-r--r--openwrt/package/elhttp/Makefile38
-rw-r--r--openwrt/package/elhttp/ipkg/elhttp.control4
-rw-r--r--openwrt/package/elhttp/patches/01-cross-compile.patch21
4 files changed, 0 insertions, 71 deletions
diff --git a/openwrt/package/elhttp/Config.in b/openwrt/package/elhttp/Config.in
deleted file mode 100644
index 979a267..0000000
--- a/openwrt/package/elhttp/Config.in
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_PACKAGE_ELHTTP
- prompt "elhttp............................ The extra-light http proxy server."
- tristate
- default m if CONFIG_DEVEL
- help
- The extra-light http proxy server. Features: keep-alive
- connections, http connect method, SSL/TLS support, ACLs
- and client requests logging.
diff --git a/openwrt/package/elhttp/Makefile b/openwrt/package/elhttp/Makefile
deleted file mode 100644
index 175f1db..0000000
--- a/openwrt/package/elhttp/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=elhttp
-PKG_VERSION:=0.22
-PKG_RELEASE:=1
-PKG_MD5SUM:=b52f68c47f709e9fc9429250eb8f954c
-
-PKG_SOURCE_URL:=http://phadej.daug.net/files/ \
- http://www.cr0.net:8040/code/network/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,ELHTTP,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
- $(MAKE) CC=$(TARGET_CC) CROSS=$(TARGET_CROSS) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- $(RSTRIP) $(PKG_INSTALL_DIR)/usr/sbin/
- touch $@
-
-$(IPKG_ELHTTP):
- mkdir -p $(IDIR_ELHTTP)
- $(CP) $(PKG_INSTALL_DIR)/* $(IDIR_ELHTTP)/
- $(RSTRIP) $(IDIR_ELHTTP)/
- $(IPKG_BUILD) $(IDIR_ELHTTP) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/elhttp/ipkg/elhttp.control b/openwrt/package/elhttp/ipkg/elhttp.control
deleted file mode 100644
index 4492e43..0000000
--- a/openwrt/package/elhttp/ipkg/elhttp.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: elhttp
-Priority: optional
-Section: net
-Description: The extra-light http proxy server.
diff --git a/openwrt/package/elhttp/patches/01-cross-compile.patch b/openwrt/package/elhttp/patches/01-cross-compile.patch
deleted file mode 100644
index f1aba59..0000000
--- a/openwrt/package/elhttp/patches/01-cross-compile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- elhttp-0.22.orig/Makefile 2004-06-18 15:32:17.000000000 +0200
-+++ elhttp-0.22/Makefile 2006-02-13 23:11:35.000000000 +0100
-@@ -1,13 +1,7 @@
--
-+all: linux
- linux:
-- gcc -O -W -Wall -o elhttp elhttp.c
-- strip elhttp
--
--sunos:
-- gcc -O -W -Wall -o elhttp elhttp.c -lsocket -lnsl
-- strip elhttp
--
--unix:
-- cc -O -o elhttp elhttp.c
-- strip elhttp
-+ $(CC) -O -W -Wall -o elhttp elhttp.c
-
-+install:
-+ install -d -m0755 $(DESTDIR)/usr/sbin
-+ install -m0755 elhttp $(DESTDIR)/usr/sbin/