summaryrefslogtreecommitdiff
path: root/openwrt/package/ipcad
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/ipcad')
-rw-r--r--openwrt/package/ipcad/Config.in12
-rw-r--r--openwrt/package/ipcad/Makefile70
-rw-r--r--openwrt/package/ipcad/ipkg/ipcad.conffiles1
-rw-r--r--openwrt/package/ipcad/ipkg/ipcad.control6
-rw-r--r--openwrt/package/ipcad/patches/01-honor_cppflags.patch11
5 files changed, 0 insertions, 100 deletions
diff --git a/openwrt/package/ipcad/Config.in b/openwrt/package/ipcad/Config.in
deleted file mode 100644
index fa5d0e9..0000000
--- a/openwrt/package/ipcad/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_IPCAD
- prompt "ipcad............................. listens for traffic on the specified interfaces"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBPCAP
- help
- This daemon listens for traffic on the specified interfaces.
- It has the built-in RSH and NetFlow engines to allow exporting
- the accounting data the same way as Cisco routers do.
-
- http://lionet.info/ipcad/
-
diff --git a/openwrt/package/ipcad/Makefile b/openwrt/package/ipcad/Makefile
deleted file mode 100644
index 21231d4..0000000
--- a/openwrt/package/ipcad/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ipcad
-PKG_VERSION:=3.7
-PKG_RELEASE:=1
-PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
-
-PKG_SOURCE_URL:=@SF/ipcad
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,IPCAD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
- touch cfglex.c cslex.c; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- --disable-rpath \
- --with-gnu-ld \
- --with-psrc=pcap \
- --with-pcap-include="$(STAGING_DIR)/usr/include" \
- --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR=$(PKG_INSTALL_DIR) \
- all install
- touch $@
-
-$(IPKG_IPCAD):
- install -d -m0755 $(IDIR_IPCAD)/etc
- $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(IDIR_IPCAD)/etc/
- install -d -m0755 $(IDIR_IPCAD)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(IDIR_IPCAD)/usr/bin/
- $(RSTRIP) $(IDIR_IPCAD)
- $(IPKG_BUILD) $(IDIR_IPCAD) $(PACKAGE_DIR)
diff --git a/openwrt/package/ipcad/ipkg/ipcad.conffiles b/openwrt/package/ipcad/ipkg/ipcad.conffiles
deleted file mode 100644
index f6843d8..0000000
--- a/openwrt/package/ipcad/ipkg/ipcad.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/ipcad.conf
diff --git a/openwrt/package/ipcad/ipkg/ipcad.control b/openwrt/package/ipcad/ipkg/ipcad.control
deleted file mode 100644
index 93df70c..0000000
--- a/openwrt/package/ipcad/ipkg/ipcad.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: ipcad
-Depends: libpcap
-Section: net
-Architecture: mipsel
-Priority: optional
-Description: IPCAD stands for IP Cisco Accounting Daemon. It runs in background, listens traffic on the specified interfaces, and records the traffic for later retrieval and analysis. IPCAD can use raw BPF devices, PCAP library, divert, tee or Linux iptables' ULOG & IPQ packet sources to capture the packets.
diff --git a/openwrt/package/ipcad/patches/01-honor_cppflags.patch b/openwrt/package/ipcad/patches/01-honor_cppflags.patch
deleted file mode 100644
index 55f9888..0000000
--- a/openwrt/package/ipcad/patches/01-honor_cppflags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN ipcad-3.7-old/Makefile.in ipcad-3.7-new/Makefile.in
---- ipcad-3.7-old/Makefile.in 2005-11-21 05:41:07.000000000 +0100
-+++ ipcad-3.7-new/Makefile.in 2005-12-20 10:27:07.000000000 +0100
-@@ -9,6 +9,7 @@
- LDFLAGS+= @LDFLAGS@
- LIBS+= @LIBS@
- CFLAGS+= @CFLAGS@ @DEFS@ -W -Wall
-+CPPFLAGS+= @CPPFLAGS@
- CPPFLAGS+=-DIPCAD_VERSION=\"@IPCAD_VERSION@\"
- CPPFLAGS+=-DCONFIG_FILE=\"${sysconfdir}/ipcad.conf\"
- CPPFLAGS+=@DEFS@ -D_REENTRANT -D_THREAD_SAFE