summaryrefslogtreecommitdiff
path: root/openwrt/package/irssi
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/irssi')
-rw-r--r--openwrt/package/irssi/Config.in11
-rw-r--r--openwrt/package/irssi/Makefile70
-rw-r--r--openwrt/package/irssi/ipkg/irssi.control5
-rw-r--r--openwrt/package/irssi/patches/100-cross_compiling_fix.patch54
4 files changed, 0 insertions, 140 deletions
diff --git a/openwrt/package/irssi/Config.in b/openwrt/package/irssi/Config.in
deleted file mode 100644
index 8a150f2..0000000
--- a/openwrt/package/irssi/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_IRSSI
- prompt "irssi............................. console irc client"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_GLIB1
- select BR2_PACKAGE_LIBNCURSES
- help
- IRC client for the text console
-
- http://irssi.org
-
diff --git a/openwrt/package/irssi/Makefile b/openwrt/package/irssi/Makefile
deleted file mode 100644
index 505c801..0000000
--- a/openwrt/package/irssi/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=irssi
-PKG_VERSION:=0.8.10
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=http://irssi.org/files/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
-PKG_MD5SUM:=38e616bccb6a34ff6d91690317c2fa19
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,IRSSI,irssi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
- ac_cv_c_bigendian=no \
- ac_cv_sizeof_off_t=8 \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --program-prefix="" \
- --with-perl=no \
- --with-glib1 \
- --with-gnu-ld \
- --with-textui \
- --without-terminfo \
- --without-bot \
- --without-file-offset-size \
- --without-ssl \
- $(DISABLE_NLS) \
- --disable-ssl \
- --disable-ipv6 \
- --disable-proxy \
- --with-glib-prefix=$(STAGING_DIR)/usr \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC)
- touch $@
-
-$(IPKG_IRSSI):
- mkdir -p $(IDIR_IRSSI)/usr/bin
- $(CP) $(PKG_BUILD_DIR)/src/fe-text/$(PKG_NAME) $(IDIR_IRSSI)/usr/bin/
- $(STRIP) $(IDIR_IRSSI)/usr/bin/*
- $(IPKG_BUILD) $(IDIR_IRSSI) $(PACKAGE_DIR)
-
-mostlyclean:
- $(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/irssi/ipkg/irssi.control b/openwrt/package/irssi/ipkg/irssi.control
deleted file mode 100644
index a6d2566..0000000
--- a/openwrt/package/irssi/ipkg/irssi.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: irssi
-Priority: optional
-Section: text
-Depends: glib1, libpthread, libncurses
-Description: IRC text client
diff --git a/openwrt/package/irssi/patches/100-cross_compiling_fix.patch b/openwrt/package/irssi/patches/100-cross_compiling_fix.patch
deleted file mode 100644
index 2b45cea..0000000
--- a/openwrt/package/irssi/patches/100-cross_compiling_fix.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -ruN irssi-0.8.10.orig/configure irssi-0.8.10/configure
---- irssi-0.8.10.orig/configure 2005-12-11 23:46:06.000000000 +0100
-+++ irssi-0.8.10/configure 2006-02-24 13:19:21.570891250 +0100
-@@ -21848,13 +21848,6 @@
-
- echo "$as_me:$LINENO: checking size of off_t" >&5
- echo $ECHO_N "checking size of off_t... $ECHO_C" >&6
--if test "$cross_compiling" = yes; then
-- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&5
--echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
-- { (exit 1); exit 1; }; }
--else
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -21872,35 +21865,8 @@
- }
-
- _ACEOF
--rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-- (eval $ac_link) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
-- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-- (eval $ac_try) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; }; then
--
-- sizeof_off_t=`cat conftestval`
-- rm -f conftestval
--
--else
-- echo "$as_me: program exited with status $ac_status" >&5
--echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--( exit $ac_status )
--
-- { { echo "$as_me:$LINENO: error: Unsupported off_t size" >&5
--echo "$as_me: error: Unsupported off_t size" >&2;}
-- { (exit 1); exit 1; }; }
--
--fi
-+ sizeof_off_t=8
- rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
--fi
- echo "$as_me:$LINENO: result: $sizeof_off_t" >&5
- echo "${ECHO_T}$sizeof_off_t" >&6
-