summaryrefslogtreecommitdiff
path: root/openwrt/package/lcd4linux
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/lcd4linux')
-rw-r--r--openwrt/package/lcd4linux/Config.in10
-rw-r--r--openwrt/package/lcd4linux/Makefile64
-rw-r--r--openwrt/package/lcd4linux/ipkg/lcd4linux.control5
-rw-r--r--openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch11
-rw-r--r--openwrt/package/lcd4linux/patches/110-ucdelay.patch12
-rw-r--r--openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch15
6 files changed, 0 insertions, 117 deletions
diff --git a/openwrt/package/lcd4linux/Config.in b/openwrt/package/lcd4linux/Config.in
deleted file mode 100644
index 9dbb1da..0000000
--- a/openwrt/package/lcd4linux/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_LCD4LINUX
- prompt "lcd4linux......................... Program to access an external LCD"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBNCURSES
- help
- LCD4Linux
-
- https://ssl.bulix.org/projects/lcd4linux/wiki/Howto
-
diff --git a/openwrt/package/lcd4linux/Makefile b/openwrt/package/lcd4linux/Makefile
deleted file mode 100644
index 09d329b..0000000
--- a/openwrt/package/lcd4linux/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=lcd4linux
-PKG_VERSION:=0.10.0+cvs20051015
-PKG_RELEASE:=1
-PKG_MD5SUM:=5b5ac629be4bb5c29104fb8f6b7fa444
-
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/lcd4linux/ \
- http://ftp.de.debian.org/debian/pool/main/l/lcd4linux/
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LCD4LINUX,lcd4linux,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --without-x \
- --with-drivers='all,!PNG,!RouterBoard,!X11' \
- --with-plugins=wireless \
- )
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
- CFLAGS="$(TARGET_CFLAGS) -Wall"
- touch $@
-
-$(IPKG_LCD4LINUX):
- install -d -m0755 $(IDIR_LCD4LINUX)/usr/bin
- install -m0755 $(PKG_BUILD_DIR)/lcd4linux $(IDIR_LCD4LINUX)/usr/bin/
- $(RSTRIP) $(IDIR_LCD4LINUX)
- $(IPKG_BUILD) $(IDIR_LCD4LINUX) $(PACKAGE_DIR)
diff --git a/openwrt/package/lcd4linux/ipkg/lcd4linux.control b/openwrt/package/lcd4linux/ipkg/lcd4linux.control
deleted file mode 100644
index f4809f0..0000000
--- a/openwrt/package/lcd4linux/ipkg/lcd4linux.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: lcd4linux
-Priority: optional
-Section: apps
-Description: lcd software
-Depends: libncurses
diff --git a/openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch b/openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch
deleted file mode 100644
index fc9cbb4..0000000
--- a/openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lcd4linux-0.10.0-RC1/drv_RouterBoard.c 2004-08-30 15:20:45.000000000 +0200
-+++ lcd-patched/drv_RouterBoard.c 2005-03-19 16:03:26.849650830 +0100
-@@ -113,7 +113,7 @@
- #include <string.h>
- #include <errno.h>
- #include <unistd.h>
--#include <sys/io.h>
-+#include <asm/io.h>
-
- #include "debug.h"
- #include "cfg.h"
diff --git a/openwrt/package/lcd4linux/patches/110-ucdelay.patch b/openwrt/package/lcd4linux/patches/110-ucdelay.patch
deleted file mode 100644
index 0908973..0000000
--- a/openwrt/package/lcd4linux/patches/110-ucdelay.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN lcd4linux.old/udelay.h lcd4linux.dev/udelay.h
---- lcd4linux.old/udelay.h 2005-05-08 06:32:45.000000000 +0200
-+++ lcd4linux.dev/udelay.h 2006-01-20 03:50:36.806897500 +0100
-@@ -76,7 +76,7 @@
- /* REP NOP (PAUSE) is a good thing to insert into busy-wait loops. */
- static inline void rep_nop(void)
- {
-- __asm__ __volatile__("rep; nop");
-+ __asm__ __volatile__("nop");
- }
-
-
diff --git a/openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch b/openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch
deleted file mode 100644
index 3769324..0000000
--- a/openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -urN lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.c
---- lcd4linux.old/drv_generic_parport.c 2006-01-20 03:52:18.426419500 +0100
-+++ lcd4linux.dev/drv_generic_parport.c 2006-01-20 03:57:59.205263500 +0100
-@@ -134,6 +134,11 @@
- #define PARPORT_STATUS_BUSY 0x80
- #endif
-
-+#ifndef WITH_OUTB
-+#define inb(foo) 0
-+#define outb(foo,bar) 0
-+#endif
-+
- #if !defined(WITH_OUTB) && !defined(WITH_PPDEV)
- #error neither outb() nor ppdev() possible
- #error cannot compile parallel port driver