summaryrefslogtreecommitdiff
path: root/openwrt/package/libcli
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/libcli')
-rw-r--r--openwrt/package/libcli/Config.in11
-rwxr-xr-xopenwrt/package/libcli/Makefile53
-rwxr-xr-xopenwrt/package/libcli/ipkg/libcli.control5
-rw-r--r--openwrt/package/libcli/patches/01-remove_debug_honor_prefix.patch19
4 files changed, 0 insertions, 88 deletions
diff --git a/openwrt/package/libcli/Config.in b/openwrt/package/libcli/Config.in
deleted file mode 100644
index a7a187c..0000000
--- a/openwrt/package/libcli/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_LIBCLI
- prompt "libcli............................ A Cisco-like command line interface"
- tristate
- default m if CONFIG_DEVEL
- help
- Provides a shared library for including a Cisco-like
- command-line interface into other software. It's a telnet
- interface which supports command-line editing, history,
- authentication and callbacks for a user-definable function tree
-
- http://libcli.sourceforge.net/
diff --git a/openwrt/package/libcli/Makefile b/openwrt/package/libcli/Makefile
deleted file mode 100755
index 398ee09..0000000
--- a/openwrt/package/libcli/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libcli
-PKG_VERSION:=1.8.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=0fdd30df5a8c1388a4549751ba61247a
-
-PKG_SOURCE_URL:=@SF/libcli
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBCLI,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) CC=$(TARGET_CC) LD=$(TARGET_CC) \
- DESTDIR=$(PKG_INSTALL_DIR) \
- -C $(PKG_BUILD_DIR) install
- touch $@
-
-$(IPKG_LIBCLI):
- install -d -m0755 $(IDIR_LIBCLI)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcli* $(IDIR_LIBCLI)/usr/lib
- $(RSTRIP) $(IDIR_LIBCLI)
- $(IPKG_BUILD) $(IDIR_LIBCLI) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libcli.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libcli.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcli.so* $(STAGING_DIR)/usr/lib/
-
-install-dev: $(STAGING_DIR)/usr/lib/libcli.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/libcli.h \
- $(STAGING_DIR)/usr/lib/libcli.so*
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-
diff --git a/openwrt/package/libcli/ipkg/libcli.control b/openwrt/package/libcli/ipkg/libcli.control
deleted file mode 100755
index 6ef456b..0000000
--- a/openwrt/package/libcli/ipkg/libcli.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: libcli
-Section: libs
-Architecture: mipsel
-Priority: optional
-Description: Provides a shared library for including a Cisco-like command-line interface into other software. \ No newline at end of file
diff --git a/openwrt/package/libcli/patches/01-remove_debug_honor_prefix.patch b/openwrt/package/libcli/patches/01-remove_debug_honor_prefix.patch
deleted file mode 100644
index 830baa0..0000000
--- a/openwrt/package/libcli/patches/01-remove_debug_honor_prefix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -urN orig/libcli-1.8.5/Makefile libcli-1.8.5/Makefile
---- orig/libcli-1.8.5/Makefile 2005-05-02 11:57:39.000000000 +0200
-+++ libcli-1.8.5/Makefile 2005-12-13 17:42:46.000000000 +0100
-@@ -1,13 +1,12 @@
- DESTDIR =
--PREFIX = /usr/local
-+PREFIX = /usr/
-
- MAJOR = 1
- MINOR = 8
- REVISION = 5
- LIB = libcli.so
-
--CC = gcc
--DEBUG = -g
-+DEBUG =
- OPTIM = -O3
- CFLAGS += $(DEBUG) $(OPTIM) -Wall -Wformat-security -Wno-format-zero-length
- LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR).$(MINOR)