summaryrefslogtreecommitdiff
path: root/openwrt/package/libgd
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/libgd')
-rw-r--r--openwrt/package/libgd/Config.in11
-rw-r--r--openwrt/package/libgd/Makefile95
-rw-r--r--openwrt/package/libgd/ipkg/libgd.control5
-rw-r--r--openwrt/package/libgd/patches/100-configure_fix.patch40
4 files changed, 0 insertions, 151 deletions
diff --git a/openwrt/package/libgd/Config.in b/openwrt/package/libgd/Config.in
deleted file mode 100644
index 8c513bd..0000000
--- a/openwrt/package/libgd/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_LIBGD
- prompt "libgd............................. The GD Graphics Library"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBJPEG
- select BR2_PACKAGE_LIBPNG
- help
- The GD Graphics Library
-
- http://www.boutell.com/gd/
-
diff --git a/openwrt/package/libgd/Makefile b/openwrt/package/libgd/Makefile
deleted file mode 100644
index 88933e7..0000000
--- a/openwrt/package/libgd/Makefile
+++ /dev/null
@@ -1,95 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gd
-PKG_VERSION:=2.0.33
-PKG_RELEASE:=2
-PKG_MD5SUM:=be0a6d326cd8567e736fbc75df0a5c45
-
-PKG_SOURCE_URL:=http://www.boutell.com/gd/http
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBGD,libgd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- LIBPNG12_CONFIG="$(STAGING_DIR)/usr/bin/libpng12-config" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --enable-static \
- --disable-rpath \
- --with-gnu-ld \
- --without-x \
- --without-freetype \
- --with-jpeg=$(STAGING_DIR)/usr \
- --with-png=$(STAGING_DIR)/usr \
- --without-xpm \
- )
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_LIBGD):
- install -d -m0755 $(IDIR_LIBGD)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.so.* $(IDIR_LIBGD)/usr/lib/
- $(RSTRIP) $(IDIR_LIBGD)
- $(IPKG_BUILD) $(IDIR_LIBGD) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libgd.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(STAGING_DIR)/usr/bin/
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/entities.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/gd*.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libgd.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/bin/gdlib-config \
- $(STAGING_DIR)/usr/include/entities.h \
- $(STAGING_DIR)/usr/include/gd*.h \
- $(STAGING_DIR)/usr/lib/libgd.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-
diff --git a/openwrt/package/libgd/ipkg/libgd.control b/openwrt/package/libgd/ipkg/libgd.control
deleted file mode 100644
index f6a78e5..0000000
--- a/openwrt/package/libgd/ipkg/libgd.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: libgd
-Priority: optional
-Section: libs
-Depends: libjpeg, libpng
-Description: A library for the dynamic creation of images
diff --git a/openwrt/package/libgd/patches/100-configure_fix.patch b/openwrt/package/libgd/patches/100-configure_fix.patch
deleted file mode 100644
index dd7d6bc..0000000
--- a/openwrt/package/libgd/patches/100-configure_fix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -urN gd-2.0.33.old/configure gd-2.0.33.dev/configure
---- gd-2.0.33.old/configure 2004-11-04 00:14:47.000000000 +0100
-+++ gd-2.0.33.dev/configure 2005-05-05 15:06:26.000000000 +0200
-@@ -7217,8 +7217,6 @@
- shlibpath_overrides_runpath=unknown
- version_type=none
- dynamic_linker="$host_os ld.so"
--sys_lib_dlsearch_path_spec="/lib /usr/lib"
--sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
-
- case $host_os in
- aix3*)
-@@ -7481,8 +7479,6 @@
- *)
- ;;
- esac
-- sys_lib_dlsearch_path_spec="/lib${libsuff} /usr/lib${libsuff}"
-- sys_lib_search_path_spec="/lib${libsuff} /usr/lib${libsuff} /usr/local/lib${libsuff}"
- ;;
-
- netbsd*)
-@@ -11032,14 +11028,14 @@
- fi
-
- if test -n "$LIBPNG12_CONFIG"; then
-- libpng_CPPFLAGS=`libpng12-config --cflags`
-+ libpng_CPPFLAGS=`$LIBPNG12_CONFIG --cflags`
- # should be --ldopts, but it's currently broken
-- libpng_LDFLAGS=`libpng12-config --ldflags`
-+ libpng_LDFLAGS=`$LIBPNG12_CONFIG --ldflags`
- libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[^ ][^ ]*//g'`
- elif test -n "$LIBPNG_CONFIG"; then
-- libpng_CPPFLAGS=`libpng-config --cflags`
-+ libpng_CPPFLAGS=`$LIBPNG_CONFIG --cflags`
- # should be --ldopts, but it's currently broken
-- libpng_LDFLAGS=`libpng-config --ldflags`
-+ libpng_LDFLAGS=`$LIBPNG_CONFIG --ldflags`
- libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[^ ][^ ]*//g'`
- elif test -d "$withval"; then
- libpng_CPPFLAGS="-I$withval/include"