summaryrefslogtreecommitdiff
path: root/openwrt/package/libnids
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/libnids')
-rw-r--r--openwrt/package/libnids/Config.in11
-rw-r--r--openwrt/package/libnids/Makefile83
-rw-r--r--openwrt/package/libnids/ipkg/libnids.control5
-rw-r--r--openwrt/package/libnids/patches/configure.patch62
-rw-r--r--openwrt/package/libnids/patches/no_asm_for_i386.patch12
5 files changed, 0 insertions, 173 deletions
diff --git a/openwrt/package/libnids/Config.in b/openwrt/package/libnids/Config.in
deleted file mode 100644
index 0c98be2..0000000
--- a/openwrt/package/libnids/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_LIBNIDS
- prompt "libnids........................... A network intrusion detection library"
- tristate
- select BR2_PACKAGE_LIBPCAP
- select BR2_PACKAGE_LIBNET
- default m if CONFIG_DEVEL
- help
- An implementation of an E-component of Network Intrusion Detection System.
-
- http://www.packetfactory.net/projects/libnids/
-
diff --git a/openwrt/package/libnids/Makefile b/openwrt/package/libnids/Makefile
deleted file mode 100644
index c7e271e..0000000
--- a/openwrt/package/libnids/Makefile
+++ /dev/null
@@ -1,83 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libnids
-PKG_VERSION:=1.18
-PKG_RELEASE:=0
-PKG_MD5SUM:=9ee6dcdfac97bae6fe611aa27d2594a5
-
-PKG_SOURCE_URL:=http://www.packetfactory.net/projects/libnids/dist/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBNIDS,libnids,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared \
- --enable-static \
- --with-libnet="$(STAGING_DIR)/usr" \
- --with-libpcap="$(STAGING_DIR)/usr" \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- install_prefix="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_LIBNIDS):
- install -m0755 -d $(IDIR_LIBNIDS)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnids.so.* $(IDIR_LIBNIDS)/usr/lib/
- $(RSTRIP) $(IDIR_LIBNIDS)
- $(IPKG_BUILD) $(IDIR_LIBNIDS) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libnids.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/nids.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnids.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $(STAGING_DIR)/usr/lib/libnids.so
-
-install-dev: $(STAGING_DIR)/usr/lib/libnids.so
-
-uninstall-dev:
- rm -rf $(STAGING_DIR)/usr/include/nids.h
- rm -rf $(STAGING_DIR)/usr/lib/libnids.{a,so*}
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/libnids/ipkg/libnids.control b/openwrt/package/libnids/ipkg/libnids.control
deleted file mode 100644
index f342742..0000000
--- a/openwrt/package/libnids/ipkg/libnids.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: libnids
-Priority: optional
-Section: libs
-Description: implementation of an E-component of Network Intrusion Detection System.
-Depends: libpcap, libnet
diff --git a/openwrt/package/libnids/patches/configure.patch b/openwrt/package/libnids/patches/configure.patch
deleted file mode 100644
index 3b56aba..0000000
--- a/openwrt/package/libnids/patches/configure.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -Nur libnids-1.18/configure libnids-1.18.patched/configure
---- libnids-1.18/configure 2003-10-15 01:40:09.000000000 +0200
-+++ libnids-1.18.patched/configure 2005-06-09 12:37:42.000000000 +0200
-@@ -3253,7 +3253,7 @@
- esac
-
-
--CFLAGS="$CFLAGS -D_BSD_SOURCE"
-+CFLAGS="$CFLAGS"
-
- for ac_func in gettimeofday
- do
-@@ -3489,17 +3489,21 @@
- echo "${ECHO_T}no" >&6
- ;;
- *)
-- echo "$as_me:$LINENO: result: $withval" >&5
--echo "${ECHO_T}$withval" >&6
-+ echo "$ac_t""$withval" 1>&6
- if test -f $withval/pcap.h -a -f $withval/libpcap.a; then
- owd=`pwd`
- if cd $withval; then withval=`pwd`; cd $owd; fi
-- PCAP_CFLAGS="-I$withval -I$withval/bpf"
-+ PCAPINC="-I$withval -I$withval/bpf"
- PCAPLIB="-L$withval -lpcap"
-+ elif test -f $withval/include/pcap.h -a \
-+ -f $withval/include/pcap-bpf.h -a \
-+ -f $withval/lib/libpcap.a; then
-+ owd=`pwd`
-+ if cd $withval; then withval=`pwd`; cd $owd; fi
-+ PCAPINC="-I$withval/include"
-+ PCAPLIB="-L$withval/lib -lpcap"
- else
-- { { echo "$as_me:$LINENO: error: pcap.h or libpcap.a not found in $withval" >&5
--echo "$as_me: error: pcap.h or libpcap.a not found in $withval" >&2;}
-- { (exit 1); exit 1; }; }
-+ { echo "configure: error: pcap.h" 1>&2; exit 1; }
- fi
- ;;
- esac
-@@ -3605,10 +3609,10 @@
- *)
- echo "$as_me:$LINENO: result: $withval" >&5
- echo "${ECHO_T}$withval" >&6
-- if test -f $withval/include/libnet.h -a -f $withval/lib/libnet.a -a -f $withval/libnet-config ; then
-+ if test -f $withval/include/libnet.h -a -f $withval/lib/libnet.a -a -f $withval/bin/libnet-config ; then
- owd=`pwd`
- if cd $withval; then withval=`pwd`; cd $owd; fi
-- LNET_CFLAGS="-I$withval/include `$withval/libnet-config --defines`"
-+ LNET_CFLAGS="-I$withval/include `$withval/bin/libnet-config --defines`"
- LNETLIB="-L$withval/lib -lnet"
- elif test -f $withval/include/libnet.h -a -f $withval/src/libnet.a; then
- owd=`pwd`
-@@ -3861,7 +3865,7 @@
- else
- echo "$as_me: failed program was:" >&5
- cat conftest.$ac_ext >&5
--HAVE_BSD_UDPHDR=0
-+HAVE_BSD_UDPHDR=1
- fi
- rm -f conftest.$ac_objext conftest.$ac_ext
-
diff --git a/openwrt/package/libnids/patches/no_asm_for_i386.patch b/openwrt/package/libnids/patches/no_asm_for_i386.patch
deleted file mode 100644
index ff6fde7..0000000
--- a/openwrt/package/libnids/patches/no_asm_for_i386.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN libnids-1.18-orig/src/checksum.c libnids-1.18/src/checksum.c
---- libnids-1.18-orig/src/checksum.c 2003-09-20 22:40:44.000000000 +0200
-+++ libnids-1.18/src/checksum.c 2005-08-09 23:55:00.000000000 +0200
-@@ -4,7 +4,7 @@
- #include <netinet/tcp.h>
- #include <netinet/udp.h>
-
--#if ( __i386__ || __i386 )
-+#if 0
- // all asm procedures are copied from Linux 2.0.36 and 2.2.10 kernels
-
- /*