summaryrefslogtreecommitdiff
path: root/openwrt/package/libtasn1
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/libtasn1')
-rw-r--r--openwrt/package/libtasn1/Config.in11
-rw-r--r--openwrt/package/libtasn1/Makefile102
-rw-r--r--openwrt/package/libtasn1/ipkg/libtasn1.control4
-rw-r--r--openwrt/package/libtasn1/patches/500-cross-compile.patch28
4 files changed, 0 insertions, 145 deletions
diff --git a/openwrt/package/libtasn1/Config.in b/openwrt/package/libtasn1/Config.in
deleted file mode 100644
index 4553c25..0000000
--- a/openwrt/package/libtasn1/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_LIBTASN1
- prompt "libtasn1.......................... An ASN.1 and DER structures manipulation library"
- tristate
-# default m if CONFIG_DEVEL
- default n
- help
- This is a library for Abstract Syntax Notation One (ASN.1) and
- Distinguish Encoding Rules (DER) manipulation.
-
- ftp://ftp.gnutls.org/pub/gnutls/libtasn1/
-
diff --git a/openwrt/package/libtasn1/Makefile b/openwrt/package/libtasn1/Makefile
deleted file mode 100644
index 9402aa5..0000000
--- a/openwrt/package/libtasn1/Makefile
+++ /dev/null
@@ -1,102 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libtasn1
-PKG_VERSION:=0.2.13
-PKG_RELEASE:=0
-PKG_MD5SUM:=d124b11908cfb88883fe71472c25d53a
-
-PKG_SOURCE_URL:=ftp://ftp.gnutls.org/pub/gnutls/libtasn1/ \
- ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/libtasn1/ \
- http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
- ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/libtasn1/ \
- http://josefsson.org/gnutls/releases/libtasn1/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBTASN1,libtasn1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- touch configure.ac ; \
- touch acinclude.m4 ; \
- touch aclocal.m4 ; \
- touch Makefile.in ; \
- touch config.h.in ; \
- touch configure ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared \
- --enable-static \
- --disable-rpath \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_LIBTASN1):
- install -m0755 -d $(IDIR_LIBTASN1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.so.* $(IDIR_LIBTASN1)/usr/lib/
- $(RSTRIP) $(IDIR_LIBTASN1)
- $(IPKG_BUILD) $(IDIR_LIBTASN1) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libtasn1.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/libtasn1-config $(STAGING_DIR)/usr/bin/
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libtasn1.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libtasn1.{a,so*} $(STAGING_DIR)/usr/lib/
- mkdir -p $(STAGING_DIR)/usr/share/aclocal
- $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libtasn1.m4 $(STAGING_DIR)/usr/share/aclocal/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libtasn1.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/bin/libtasn1-config \
- $(STAGING_DIR)/usr/include/libtasn1.h \
- $(STAGING_DIR)/usr/lib/libtasn1.{a,so*} \
- $(STAGING_DIR)/usr/share/aclocal/libtasn1.m4 \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-
-mostlyclean:
- make -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/libtasn1/ipkg/libtasn1.control b/openwrt/package/libtasn1/ipkg/libtasn1.control
deleted file mode 100644
index 4a5c1f6..0000000
--- a/openwrt/package/libtasn1/ipkg/libtasn1.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: libtasn1
-Priority: optional
-Section: libs
-Description: an ASN.1 and DER structures manipulation library
diff --git a/openwrt/package/libtasn1/patches/500-cross-compile.patch b/openwrt/package/libtasn1/patches/500-cross-compile.patch
deleted file mode 100644
index dadbf2b..0000000
--- a/openwrt/package/libtasn1/patches/500-cross-compile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ruN libtasn1-0.2.13-orig/configure libtasn1-0.2.13-1/configure
---- libtasn1-0.2.13-orig/configure 2004-12-15 19:40:02.000000000 +0100
-+++ libtasn1-0.2.13-1/configure 2005-03-15 22:35:56.000000000 +0100
-@@ -22448,8 +22448,8 @@
-
-
-
--LIBTASN1_LIBS="-L${libdir} -ltasn1 $LIBS"
--LIBTASN1_CFLAGS="-I${includedir}"
-+LIBTASN1_LIBS="-ltasn1 $LIBS"
-+LIBTASN1_CFLAGS=""
-
-
-
-diff -ruN libtasn1-0.2.13-orig/configure.in libtasn1-0.2.13-1/configure.in
---- libtasn1-0.2.13-orig/configure.in 2004-12-15 19:39:01.000000000 +0100
-+++ libtasn1-0.2.13-1/configure.in 2005-03-15 22:35:46.000000000 +0100
-@@ -85,8 +85,8 @@
- ])
- AM_PROG_LIBTOOL
-
--LIBTASN1_LIBS="-L${libdir} -ltasn1 $LIBS"
--LIBTASN1_CFLAGS="-I${includedir}"
-+LIBTASN1_LIBS="-ltasn1 $LIBS"
-+LIBTASN1_CFLAGS=""
-
- AC_SUBST(LIBTASN1_LIBS)
- AC_SUBST(LIBTASN1_CFLAGS)