summaryrefslogtreecommitdiff
path: root/openwrt/package/lua
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/lua')
-rw-r--r--openwrt/package/lua/Config.in111
-rw-r--r--openwrt/package/lua/Makefile100
-rw-r--r--openwrt/package/lua/ipkg/liblua.control4
-rw-r--r--openwrt/package/lua/ipkg/lua-examples.control5
-rw-r--r--openwrt/package/lua/ipkg/lua.control5
-rw-r--r--openwrt/package/lua/ipkg/luac.control5
-rw-r--r--openwrt/package/lua/patches/lua-5.0.2-config.patch31
-rw-r--r--openwrt/package/lua/patches/lua-5.0.2-soname.patch14
8 files changed, 0 insertions, 275 deletions
diff --git a/openwrt/package/lua/Config.in b/openwrt/package/lua/Config.in
deleted file mode 100644
index fc25826..0000000
--- a/openwrt/package/lua/Config.in
+++ /dev/null
@@ -1,111 +0,0 @@
-menu "lua............................... LUA programming language"
-
-config BR2_COMPILE_LUA
- tristate
- default n
- depends BR2_PACKAGE_LIBLUA
-
-config BR2_PACKAGE_LIBLUA
- prompt "liblua............................ LUA programming language shared libraries"
- tristate
- select BR2_COMPILE_LUA
- help
- Lua is a powerful light-weight programming language designed for extending
- applications. Lua is also frequently used as a general-purpose, stand-alone
- language. Lua is free software.
-
- Lua combines simple procedural syntax with powerful data description
- constructs based on associative arrays and extensible semantics. Lua is
- dynamically typed, interpreted from bytecodes, and has automatic memory
- management with garbage collection, making it ideal for configuration,
- scripting, and rapid prototyping.
-
- Lua is implemented as a small library of C functions, written in ANSI C, and
- compiles unmodified in all known platforms. The implementation goals are
- simplicity, efficiency, portability, and low embedding cost. The result is a
- fast language engine with small footprint, making it ideal in embedded systems
- too.
-
- http://www.lua.org/
-
- This package contains the LUA shared libraries, needed by other programs.
-
-config BR2_PACKAGE_LUA
- prompt "lua............................... LUA programming language interpreter"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBLUA
- help
- Lua is a powerful light-weight programming language designed for extending
- applications. Lua is also frequently used as a general-purpose, stand-alone
- language. Lua is free software.
-
- Lua combines simple procedural syntax with powerful data description
- constructs based on associative arrays and extensible semantics. Lua is
- dynamically typed, interpreted from bytecodes, and has automatic memory
- management with garbage collection, making it ideal for configuration,
- scripting, and rapid prototyping.
-
- Lua is implemented as a small library of C functions, written in ANSI C, and
- compiles unmodified in all known platforms. The implementation goals are
- simplicity, efficiency, portability, and low embedding cost. The result is a
- fast language engine with small footprint, making it ideal in embedded systems
- too.
-
- http://www.lua.org/
-
- This package contains the LUA language interpreter.
-
-config BR2_PACKAGE_LUAC
- prompt "luac.............................. LUA programming language compiler"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBLUA
- help
- Lua is a powerful light-weight programming language designed for extending
- applications. Lua is also frequently used as a general-purpose, stand-alone
- language. Lua is free software.
-
- Lua combines simple procedural syntax with powerful data description
- constructs based on associative arrays and extensible semantics. Lua is
- dynamically typed, interpreted from bytecodes, and has automatic memory
- management with garbage collection, making it ideal for configuration,
- scripting, and rapid prototyping.
-
- Lua is implemented as a small library of C functions, written in ANSI C, and
- compiles unmodified in all known platforms. The implementation goals are
- simplicity, efficiency, portability, and low embedding cost. The result is a
- fast language engine with small footprint, making it ideal in embedded systems
- too.
-
- http://www.lua.org/
-
- This package contains the LUA language compiler.
-
-config BR2_PACKAGE_LUA_EXAMPLES
- prompt "lua-examples...................... LUA programming language examples"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LUA
- help
- Lua is a powerful light-weight programming language designed for extending
- applications. Lua is also frequently used as a general-purpose, stand-alone
- language. Lua is free software.
-
- Lua combines simple procedural syntax with powerful data description
- constructs based on associative arrays and extensible semantics. Lua is
- dynamically typed, interpreted from bytecodes, and has automatic memory
- management with garbage collection, making it ideal for configuration,
- scripting, and rapid prototyping.
-
- Lua is implemented as a small library of C functions, written in ANSI C, and
- compiles unmodified in all known platforms. The implementation goals are
- simplicity, efficiency, portability, and low embedding cost. The result is a
- fast language engine with small footprint, making it ideal in embedded systems
- too.
-
- http://www.lua.org/
-
- This package contains LUA language examples.
-
-endmenu
diff --git a/openwrt/package/lua/Makefile b/openwrt/package/lua/Makefile
deleted file mode 100644
index ae6d085..0000000
--- a/openwrt/package/lua/Makefile
+++ /dev/null
@@ -1,100 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=lua
-PKG_VERSION:=5.0.2
-PKG_RELEASE:=1
-PKG_MD5SUM:= dea74646b7e5c621fef7174df83c34b1
-
-PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
- http://ftp.gwdg.de/pub/languages/lua/ \
- http://mirrors.dotsrc.org/lua/ \
- http://www.tecgraf.puc-rio.br/lua/ftp/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBLUA,liblua,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,LUA,lua,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,LUAC,luac,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,LUA_EXAMPLES,lua-examples,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CROSS)gcc" \
- LD="$(TARGET_CROSS)ld" \
- AR="$(TARGET_CROSS)ar rcu" \
- RANLIB="$(TARGET_CROSS)ranlib" \
- INSTALL_ROOT=/usr \
- MYCFLAGS="-I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
- MYLDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- all so
- # remove statically linked binaries, so that they will get linked against shlib this time
- rm -f $(PKG_BUILD_DIR)/bin/lua{,c}
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CROSS)gcc" \
- LD="$(TARGET_CROSS)ld" \
- AR="$(TARGET_CROSS)ar rcu" \
- RANLIB="$(TARGET_CROSS)ranlib" \
- INSTALL_ROOT=/usr \
- MYCFLAGS="-I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
- MYLDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- all
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- INSTALL_ROOT="$(PKG_INSTALL_DIR)/usr" \
- install soinstall
- touch $@
-
-$(IPKG_LIBLUA):
- install -d -m0755 $(IDIR_LIBLUA)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua{,lib}.so.* $(IDIR_LIBLUA)/usr/lib/
- $(RSTRIP) $(IDIR_LIBLUA)
- $(IPKG_BUILD) $(IDIR_LIBLUA) $(PACKAGE_DIR)
-
-$(IPKG_LUA):
- install -d -m0755 $(IDIR_LUA)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/lua $(IDIR_LUA)/usr/bin/
- $(RSTRIP) $(IDIR_LUA)
- $(IPKG_BUILD) $(IDIR_LUA) $(PACKAGE_DIR)
-
-$(IPKG_LUAC):
- install -d -m0755 $(IDIR_LUAC)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/luac $(IDIR_LUAC)/usr/bin/
- $(RSTRIP) $(IDIR_LUAC)
- $(IPKG_BUILD) $(IDIR_LUAC) $(PACKAGE_DIR)
-
-$(IPKG_LUA_EXAMPLES):
- install -d -m0755 $(IDIR_LUA_EXAMPLES)/usr/share/lua/examples
- install -m0644 $(PKG_BUILD_DIR)/test/*.lua \
- $(IDIR_LUA_EXAMPLES)/usr/share/lua/examples/
- $(RSTRIP) $(IDIR_LUA_EXAMPLES)
- $(IPKG_BUILD) $(IDIR_LUA_EXAMPLES) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/liblua.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/lua{,lib}.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/lauxlib.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua{,lib}.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/liblua.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/lua{,lib}.h \
- $(STAGING_DIR)/usr/include/lauxlib.h \
- $(STAGING_DIR)/usr/lib/liblua{,lib}.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/lua/ipkg/liblua.control b/openwrt/package/lua/ipkg/liblua.control
deleted file mode 100644
index 502523a..0000000
--- a/openwrt/package/lua/ipkg/liblua.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: liblua
-Priority: optional
-Section: libs
-Description: LUA programming language shared libraries
diff --git a/openwrt/package/lua/ipkg/lua-examples.control b/openwrt/package/lua/ipkg/lua-examples.control
deleted file mode 100644
index fc0e46e..0000000
--- a/openwrt/package/lua/ipkg/lua-examples.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: lua-examples
-Priority: optional
-Section: devel
-Description: LUA programming language examples
-Depends: lua
diff --git a/openwrt/package/lua/ipkg/lua.control b/openwrt/package/lua/ipkg/lua.control
deleted file mode 100644
index a938103..0000000
--- a/openwrt/package/lua/ipkg/lua.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: lua
-Priority: optional
-Section: admin
-Description: LUA programming language interpreter
-Depends: liblua
diff --git a/openwrt/package/lua/ipkg/luac.control b/openwrt/package/lua/ipkg/luac.control
deleted file mode 100644
index f379f9e..0000000
--- a/openwrt/package/lua/ipkg/luac.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: luac
-Priority: optional
-Section: devel
-Description: LUA programming language compiler
-Depends: liblua
diff --git a/openwrt/package/lua/patches/lua-5.0.2-config.patch b/openwrt/package/lua/patches/lua-5.0.2-config.patch
deleted file mode 100644
index fa5b0e7..0000000
--- a/openwrt/package/lua/patches/lua-5.0.2-config.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -ruN lua-5.0.2-orig/config lua-5.0.2-1/config
---- lua-5.0.2-orig/config 2003-04-11 16:00:41.000000000 +0200
-+++ lua-5.0.2-1/config 2005-05-25 11:23:35.000000000 +0200
-@@ -25,15 +25,15 @@
- # interface (e.g., Linux, Solaris, IRIX, BSD, AIX, HPUX, and probably others),
- # uncomment the next two lines.
- #
--#LOADLIB= -DUSE_DLOPEN=1
--#DLLIB= -ldl
-+LOADLIB= -DUSE_DLOPEN=1
-+DLLIB= -ldl
- #
- # In Linux with gcc, you should also uncomment the next definition for
- # MYLDFLAGS, which passes -E (= -export-dynamic) to the linker. This option
- # allows dynamic libraries to link back to the `lua' program, so that they do
- # not need the Lua libraries. (Other systems may have an equivalent facility.)
- #
--#MYLDFLAGS= -Wl,-E
-+MYLDFLAGS= -Wl,-E
- #
- # On Windows systems. support for dynamic loading is enabled by default.
- # To disable this support, uncomment the next line.
-@@ -142,7 +142,7 @@
-
- # This should work in all Unix systems, but you may want to add options.
- #
--STRIP= strip
-+STRIP= /bin/true
-
- # ------------------------------------------------------------------ install
-
diff --git a/openwrt/package/lua/patches/lua-5.0.2-soname.patch b/openwrt/package/lua/patches/lua-5.0.2-soname.patch
deleted file mode 100644
index 3364ff6..0000000
--- a/openwrt/package/lua/patches/lua-5.0.2-soname.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ruN lua-5.0.2-orig/Makefile lua-5.0.2-1/Makefile
---- lua-5.0.2-orig/Makefile 2004-03-12 02:50:55.000000000 +0100
-+++ lua-5.0.2-1/Makefile 2005-05-25 11:41:44.000000000 +0200
-@@ -38,8 +38,8 @@
-
- # shared libraries (for Linux)
- so:
-- ld -o lib/liblua.so.$V -shared src/*.o
-- ld -o lib/liblualib.so.$V -shared src/lib/*.o
-+ $(LD) -o lib/liblua.so.$V -shared -soname="liblua.so.$V" src/*.o
-+ $(LD) -o lib/liblualib.so.$V -shared -soname="liblualib.so.$V" src/lib/*.o
- cd lib; ln -fs liblua.so.$V liblua.so; ln -fs liblualib.so.$V liblualib.so
-
- # binaries using shared libraries