summaryrefslogtreecommitdiff
path: root/openwrt/package/miredo
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/miredo')
-rw-r--r--openwrt/package/miredo/Config.in44
-rw-r--r--openwrt/package/miredo/Makefile94
-rw-r--r--openwrt/package/miredo/files/miredo-server.init28
-rw-r--r--openwrt/package/miredo/files/miredo.init28
-rw-r--r--openwrt/package/miredo/ipkg/miredo-server.conffiles1
-rw-r--r--openwrt/package/miredo/ipkg/miredo-server.control5
-rw-r--r--openwrt/package/miredo/ipkg/miredo.conffiles1
-rw-r--r--openwrt/package/miredo/ipkg/miredo.control5
8 files changed, 0 insertions, 206 deletions
diff --git a/openwrt/package/miredo/Config.in b/openwrt/package/miredo/Config.in
deleted file mode 100644
index eadca0a..0000000
--- a/openwrt/package/miredo/Config.in
+++ /dev/null
@@ -1,44 +0,0 @@
-config BR2_COMPILE_MIREDO
- tristate
- default n
- depends BR2_PACKAGE_MIREDO || BR2_PACKAGE_MIREDO_SERVER
-
-config BR2_PACKAGE_MIREDO
- prompt "miredo............................ Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_COMPILE_MIREDO
- select BR2_PACKAGE_KMOD_IPV6
- select BR2_PACKAGE_KMOD_TUN
- select BR2_PACKAGE_LIBPTHREAD
- select BR2_PACKAGE_UCLIBCXX
- help
- A Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon.
-
- http://www.simphalempin.com/dev/miredo/
-
- Depends:
- - kmod-ipv6
- - kmod-tun
- - libpthread
- - uClibc++
-
-config BR2_PACKAGE_MIREDO_SERVER
- prompt "miredo-server..................... Teredo (IPv6 tunneling over UDP through NAT) server daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_COMPILE_MIREDO
- select BR2_PACKAGE_KMOD_IPV6
- select BR2_PACKAGE_KMOD_TUN
- select BR2_PACKAGE_LIBPTHREAD
- select BR2_PACKAGE_UCLIBCXX
- help
- A Teredo (IPv6 tunneling over UDP through NAT) server daemon.
-
- http://www.simphalempin.com/dev/miredo/
-
- Depends:
- - kmod-ipv6
- - kmod-tun
- - libpthread
- - uClibc++
diff --git a/openwrt/package/miredo/Makefile b/openwrt/package/miredo/Makefile
deleted file mode 100644
index 4b98376..0000000
--- a/openwrt/package/miredo/Makefile
+++ /dev/null
@@ -1,94 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=miredo
-PKG_VERSION:=0.5.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=bbbbf60db1346af0bbba6602067ed7ab
-
-PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/miredo/v0.5/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,MIREDO,miredo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,MIREDO_SERVER,miredo-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- LIBS="-luClibc++ -lc -lm" \
- ac_cv_file__proc_self_maps=yes \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --disable-shared \
- --enable-static \
- --with-gnu-ld \
- --disable-rpath \
- --disable-chroot \
- --enable-teredo-client \
- --enable-teredo-relay \
- --enable-teredo-server \
- --enable-miredo-user=root \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CXXLINK="\$$(LINK)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_MIREDO):
- install -d -m0755 $(IDIR_MIREDO)/etc
- $(CP) $(PKG_INSTALL_DIR)/etc/miredo.conf-dist $(IDIR_MIREDO)/etc/miredo.conf
- install -d -m0755 $(IDIR_MIREDO)/etc/init.d
- install -m0755 ./files/miredo.init $(IDIR_MIREDO)/etc/init.d/miredo
- install -d -m0755 $(IDIR_MIREDO)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/miredo $(IDIR_MIREDO)/usr/sbin/
- $(RSTRIP) $(IDIR_MIREDO)
- $(IPKG_BUILD) $(IDIR_MIREDO) $(PACKAGE_DIR)
-
-$(IPKG_MIREDO_SERVER):
- install -d -m0755 $(IDIR_MIREDO_SERVER)/etc/
- $(CP) $(PKG_INSTALL_DIR)/etc/miredo-server.conf-dist $(IDIR_MIREDO_SERVER)/etc/miredo-server.conf
- install -d -m0755 $(IDIR_MIREDO_SERVER)/etc/init.d
- install -m0755 ./files/miredo-server.init $(IDIR_MIREDO_SERVER)/etc/init.d/miredo-server
- install -d -m0755 $(IDIR_MIREDO_SERVER)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/miredo-server $(IDIR_MIREDO_SERVER)/usr/sbin/
- $(RSTRIP) $(IDIR_MIREDO_SERVER)
- $(IPKG_BUILD) $(IDIR_MIREDO_SERVER) $(PACKAGE_DIR)
-
-mostlyclean:
- -$(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/miredo/files/miredo-server.init b/openwrt/package/miredo/files/miredo-server.init
deleted file mode 100644
index b41a866..0000000
--- a/openwrt/package/miredo/files/miredo-server.init
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-
-BIN=miredo-server
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- [ -d $RUN_D ] || mkdir -p $RUN_D
- insmod ipv6
- insmod tun
- $BIN $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 (start|stop|restart)"
- exit 1
-esac
-
-exit $?
diff --git a/openwrt/package/miredo/files/miredo.init b/openwrt/package/miredo/files/miredo.init
deleted file mode 100644
index e305472..0000000
--- a/openwrt/package/miredo/files/miredo.init
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-
-BIN=miredo
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- [ -d $RUN_D ] || mkdir -p $RUN_D
- insmod ipv6
- insmod tun
- $BIN $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 (start|stop|restart)"
- exit 1
-esac
-
-exit $?
diff --git a/openwrt/package/miredo/ipkg/miredo-server.conffiles b/openwrt/package/miredo/ipkg/miredo-server.conffiles
deleted file mode 100644
index ca3424b..0000000
--- a/openwrt/package/miredo/ipkg/miredo-server.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/miredo-server.conf
diff --git a/openwrt/package/miredo/ipkg/miredo-server.control b/openwrt/package/miredo/ipkg/miredo-server.control
deleted file mode 100644
index ebbc3cc..0000000
--- a/openwrt/package/miredo/ipkg/miredo-server.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: miredo-server
-Priority: optional
-Section: net
-Depends: kmod-ipv6, kmod-tun, libpthread, uclibc++
-Description: A Teredo (IPv6 tunneling over UDP through NAT) server daemon
diff --git a/openwrt/package/miredo/ipkg/miredo.conffiles b/openwrt/package/miredo/ipkg/miredo.conffiles
deleted file mode 100644
index f7428b7..0000000
--- a/openwrt/package/miredo/ipkg/miredo.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/miredo.conf
diff --git a/openwrt/package/miredo/ipkg/miredo.control b/openwrt/package/miredo/ipkg/miredo.control
deleted file mode 100644
index 2794f3b..0000000
--- a/openwrt/package/miredo/ipkg/miredo.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: miredo
-Priority: optional
-Section: net
-Depends: kmod-ipv6, kmod-tun, libpthread, uclibc++
-Description: A Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon