summaryrefslogtreecommitdiff
path: root/openwrt/package/monit
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/monit')
-rw-r--r--openwrt/package/monit/Config.in35
-rw-r--r--openwrt/package/monit/Makefile105
-rw-r--r--openwrt/package/monit/files/monit.init25
-rw-r--r--openwrt/package/monit/ipkg/monit-nossl.conffiles1
-rw-r--r--openwrt/package/monit/ipkg/monit-nossl.control5
-rw-r--r--openwrt/package/monit/ipkg/monit.conffiles1
-rw-r--r--openwrt/package/monit/ipkg/monit.control5
7 files changed, 0 insertions, 177 deletions
diff --git a/openwrt/package/monit/Config.in b/openwrt/package/monit/Config.in
deleted file mode 100644
index d8221ef..0000000
--- a/openwrt/package/monit/Config.in
+++ /dev/null
@@ -1,35 +0,0 @@
-#menu "monit............................. System services monitoring utility"
-
-config BR2_COMPILE_MONIT
- tristate
- default n
- depends BR2_PACKAGE_MONIT || BR2_PACKAGE_MONIT_NOSSL
-
-config BR2_PACKAGE_MONIT
- prompt "monit............................. System services monitoring utility, with SSL support"
- tristate
- select BR2_COMPILE_MONIT
- select BR2_PACKAGE_LIBPTHREAD
- select BR2_PACKAGE_LIBOPENSSL
- default m if CONFIG_DEVEL
- help
- An utility for monitoring services on a Unix system
-
- This package is built with SSL support.
-
- http://www.tildeslash.com/monit/
-
-config BR2_PACKAGE_MONIT_NOSSL
- prompt "monit-nossl....................... System services monitoring utility, without SSL support"
- tristate
- select BR2_COMPILE_MONIT
- select BR2_PACKAGE_LIBPTHREAD
- default m if CONFIG_DEVEL
- help
- An utility for monitoring services on a Unix system.
-
- This package is built without SSL support.
-
- http://www.tildeslash.com/monit/
-
-#endmenu
diff --git a/openwrt/package/monit/Makefile b/openwrt/package/monit/Makefile
deleted file mode 100644
index ce4b738..0000000
--- a/openwrt/package/monit/Makefile
+++ /dev/null
@@ -1,105 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=monit
-PKG_VERSION:=4.6
-PKG_RELEASE:=1
-PKG_MD5SUM:=4e53aa44e4ca264e61c7c401cee4e697
-
-PKG_SOURCE_URL:=http://www.tildeslash.com/monit/dist/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,MONIT,monit,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,MONIT_NOSSL,monit-nossl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
-ifneq ($(BR2_PACKAGE_MONIT),)
- ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/sbin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --with-ssl \
- --with-ssl-dir="$(STAGING_DIR)/usr" \
- );
- $(MAKE) -C $(PKG_BUILD_DIR)
- ( cd $(PKG_BUILD_DIR); mv monit monit-ssl; )
-endif
-ifneq ($(BR2_PACKAGE_MONIT),)
- ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/sbin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --without-ssl \
- );
- $(MAKE) -C $(PKG_BUILD_DIR)
- ( cd $(PKG_BUILD_DIR); mv monit monit-nossl; )
- $(MAKE) -C $(PKG_BUILD_DIR) clean
-endif
- touch $@
-
-$(IPKG_MONIT):
- install -d -m0755 $(IDIR_MONIT)/etc
- install -m0600 $(PKG_BUILD_DIR)/monitrc $(IDIR_MONIT)/etc/
- install -d -m0755 $(IDIR_MONIT)/etc/init.d
- install -m0755 ./files/monit.init $(IDIR_MONIT)/etc/init.d/monit
- install -d -m0755 $(IDIR_MONIT)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/monit-ssl $(IDIR_MONIT)/usr/sbin/monit
- $(RSTRIP) $(IDIR_MONIT)
- $(IPKG_BUILD) $(IDIR_MONIT) $(PACKAGE_DIR)
-
-$(IPKG_MONIT_NOSSL):
- install -d -m0755 $(IDIR_MONIT_NOSSL)/etc
- install -m0600 $(PKG_BUILD_DIR)/monitrc $(IDIR_MONIT_NOSSL)/etc/
- install -d -m0755 $(IDIR_MONIT_NOSSL)/etc/init.d
- install -m0755 ./files/monit.init $(IDIR_MONIT_NOSSL)/etc/init.d/monit
- install -d -m0755 $(IDIR_MONIT_NOSSL)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/monit-nossl $(IDIR_MONIT_NOSSL)/usr/sbin/monit
- $(RSTRIP) $(IDIR_MONIT_NOSSL)
- $(IPKG_BUILD) $(IDIR_MONIT_NOSSL) $(PACKAGE_DIR)
diff --git a/openwrt/package/monit/files/monit.init b/openwrt/package/monit/files/monit.init
deleted file mode 100644
index 50b18de..0000000
--- a/openwrt/package/monit/files/monit.init
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-BIN=monit
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- mkdir -p $RUN_D
- $BIN $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 (start|stop|restart)"
- exit 1
-esac
-exit $?
diff --git a/openwrt/package/monit/ipkg/monit-nossl.conffiles b/openwrt/package/monit/ipkg/monit-nossl.conffiles
deleted file mode 100644
index 365679c..0000000
--- a/openwrt/package/monit/ipkg/monit-nossl.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/monitrc
diff --git a/openwrt/package/monit/ipkg/monit-nossl.control b/openwrt/package/monit/ipkg/monit-nossl.control
deleted file mode 100644
index d10b711..0000000
--- a/openwrt/package/monit/ipkg/monit-nossl.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: monit-nossl
-Priority: optional
-Section: admin
-Description: An utility for system services monitoring, without SSL support.
-Depends: libpthread
diff --git a/openwrt/package/monit/ipkg/monit.conffiles b/openwrt/package/monit/ipkg/monit.conffiles
deleted file mode 100644
index 365679c..0000000
--- a/openwrt/package/monit/ipkg/monit.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/monitrc
diff --git a/openwrt/package/monit/ipkg/monit.control b/openwrt/package/monit/ipkg/monit.control
deleted file mode 100644
index 6c947d0..0000000
--- a/openwrt/package/monit/ipkg/monit.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: monit
-Priority: optional
-Section: admin
-Description: An utility for system services monitoring, with SSL support.
-Depends: libpthread, libopenssl