summaryrefslogtreecommitdiff
path: root/openwrt/package/motion/patches
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/motion/patches')
-rw-r--r--openwrt/package/motion/patches/01-ffmpeg.patch38
-rw-r--r--openwrt/package/motion/patches/02-honor_cppflags.patch20
2 files changed, 0 insertions, 58 deletions
diff --git a/openwrt/package/motion/patches/01-ffmpeg.patch b/openwrt/package/motion/patches/01-ffmpeg.patch
deleted file mode 100644
index 1f4c73e..0000000
--- a/openwrt/package/motion/patches/01-ffmpeg.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -ur motion-3.2.5.1-old/motion.c motion-3.2.5.1/motion.c
---- motion-3.2.5.1-old/motion.c 2006-03-17 10:05:13.490000000 -0800
-+++ motion-3.2.5.1/motion.c 2006-03-17 10:03:38.020000000 -0800
-@@ -1246,10 +1246,10 @@
- * Note: Negative value means SIGALRM snaps are enabled
- * httpd-control snaps are always enabled.
- */
--
-+#ifdef HAVE_FFMPEG
- /* time_current_frame is used both for snapshot and timelapse features */
- time_current_frame = cnt->currenttime;
--
-+
- if ( (cnt->conf.snapshot_interval > 0 && cnt->shots == 0 &&
- time_current_frame % cnt->conf.snapshot_interval <= time_last_frame % cnt->conf.snapshot_interval) ||
- cnt->snapshot) {
-@@ -1257,7 +1257,7 @@
- cnt->snapshot = 0;
- }
-
--
-+#endif /* HAVE_FFMPEG */
- /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
-
- #ifdef HAVE_FFMPEG
-@@ -1331,10 +1331,9 @@
- event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
-
-
--#endif /* HAVE_FFMPEG */
-
- time_last_frame = time_current_frame;
--
-+#endif /* HAVE_FFMPEG */
-
- /***** MOTION LOOP - VIDEO LOOPBACK SECTION *****/
-
-Only in motion-3.2.5.1-old/: motion.c.orig
diff --git a/openwrt/package/motion/patches/02-honor_cppflags.patch b/openwrt/package/motion/patches/02-honor_cppflags.patch
deleted file mode 100644
index 322fb77..0000000
--- a/openwrt/package/motion/patches/02-honor_cppflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
---- motion-3.2.5.1-old/Makefile.in 2006-03-07 22:52:49.000000000 +0100
-+++ motion-3.2.5.1-new/Makefile.in 2006-03-27 22:04:34.000000000 +0200
-@@ -32,6 +32,7 @@
- ################################################################################
- CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
- -Dsysconfdir=\"$(sysconfdir)\"
-+CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
- VIDEO_OBJ = @VIDEO@
-@@ -115,7 +116,7 @@
- ################################################################################
- $(DEPEND_FILE): *.h $(SRC)
- @echo "Generating dependencies, please wait..."
-- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
-+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
- @mv -f .tmp $(DEPEND_FILE)
- @echo
-