summaryrefslogtreecommitdiff
path: root/openwrt/package/openvpn
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/openvpn')
-rw-r--r--openwrt/package/openvpn/Config.in64
-rw-r--r--openwrt/package/openvpn/Makefile111
-rw-r--r--openwrt/package/openvpn/ipkg/openvpn-easy-rsa.control5
-rw-r--r--openwrt/package/openvpn/ipkg/openvpn.control4
-rw-r--r--openwrt/package/openvpn/patches/easy-rsa.patch159
5 files changed, 0 insertions, 343 deletions
diff --git a/openwrt/package/openvpn/Config.in b/openwrt/package/openvpn/Config.in
deleted file mode 100644
index e8c88e7..0000000
--- a/openwrt/package/openvpn/Config.in
+++ /dev/null
@@ -1,64 +0,0 @@
-menu "openvpn........................... Open source VPN solution using SSL"
-
-config BR2_PACKAGE_OPENVPN
- prompt "openvpn........................... Open source VPN solution using SSL"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_KMOD_TUN
- help
- Open Source VPN solution using SSL
-
- http://openvpn.net/
-
- Depends: kmod-tun, libpthread
-
-config BR2_PACKAGE_OPENVPN_EASY_RSA
- prompt "openvpn-easy-rsa................ simple shell scripts to manage a Certificate Authority"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_OPENSSL_UTIL
- depends on BR2_PACKAGE_OPENVPN
- help
- collection of shell scripts to manage a simple CA infrastructure
-
- Depends: openpvn, openssl-util
-
-config BR2_COMPILE_OPENVPN_WITH_SERVER
- prompt "Enable server support"
- bool
- default y
- depends BR2_PACKAGE_OPENVPN
-
-config BR2_COMPILE_OPENVPN_WITH_HTTP
- prompt "Enable http proxy support"
- bool
- default y
- depends BR2_PACKAGE_OPENVPN
-
-config BR2_COMPILE_OPENVPN_WITH_OPENSSL
- prompt "Enable openssl support"
- bool
- default y
- depends BR2_PACKAGE_OPENVPN
- select BR2_PACKAGE_LIBOPENSSL
-
-config BR2_COMPILE_OPENVPN_WITH_LZO
- prompt "Enable transparent compression (lzo)"
- bool
- default y
- depends BR2_PACKAGE_OPENVPN
- select BR2_PACKAGE_LIBLZO
-
-config BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE
- prompt "Enable password saving"
- bool
- default y
- depends BR2_PACKAGE_OPENVPN
-
-config BR2_COMPILE_OPENVPN_WITH_SMALL
- prompt "Enable smaller executable size (disable OCC, usage message, and verb 4 parm list)"
- bool
- default n
- depends BR2_PACKAGE_OPENVPN
-
-endmenu
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
deleted file mode 100644
index cf3017e..0000000
--- a/openwrt/package/openvpn/Makefile
+++ /dev/null
@@ -1,111 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=openvpn
-PKG_VERSION:=2.0.7
-PKG_RELEASE:=1
-PKG_MD5SUM:=93528233f1f6d02fc18e2c00f82e0aca
-
-PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,OPENVPN,openvpn,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,OPENVPN_EASY_RSA,openvpn-easy-rsa,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-PKG_DEPEND:="kmod-tun"
-
-ifneq ($(BR2_COMPILE_OPENVPN_WITH_OPENSSL),y)
-DISABLE_OPENSSL:=--disable-ssl --disable-crypto
-else
-PKG_DEPEND+=", libopenssl"
-endif
-
-ifneq ($(BR2_COMPILE_OPENVPN_WITH_LZO),y)
-DISABLE_LZO:=--disable-lzo
-else
-PKG_DEPEND+=", liblzo"
-endif
-
-ifneq ($(BR2_COMPILE_OPENVPN_WITH_SERVER),y)
-DISABLE_SERVER:=--disable-server
-endif
-ifneq ($(BR2_COMPILE_OPENVPN_WITH_HTTP),y)
-DISABLE_HTTP:=--disable-http
-endif
-ifeq ($(BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE),y)
-ENABLE_PASSWORD_SAVE:=--enable-password-save
-endif
-ifeq ($(BR2_COMPILE_OPENVPN_WITH_SMALL),y)
-ENABLE_SMALL:=--enable-small
-endif
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(strip $(TARGET_CFLAGS))" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- --disable-pthread \
- --disable-debug \
- --disable-plugins \
- --disable-management \
- --disable-socks \
- $(DISABLE_LZO) \
- $(DISABLE_OPENSSL) \
- $(DISABLE_SERVER) \
- $(DISABLE_HTTP) \
- $(ENABLE_PASSWORD_SAVE) \
- $(ENABLE_SMALL) \
- );
- touch $(PKG_BUILD_DIR)/.configured
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
-
-$(IPKG_OPENVPN):
- install -d -m0755 $(IDIR_OPENVPN)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/openvpn $(IDIR_OPENVPN)/usr/sbin/
- $(RSTRIP) $(IDIR_OPENVPN)
- echo "Depends: $(PKG_DEPEND)" >> $(IDIR_OPENVPN)/CONTROL/control
- $(IPKG_BUILD) $(IDIR_OPENVPN) $(PACKAGE_DIR)
-
-$(IPKG_OPENVPN_EASY_RSA):
- install -d -m0755 $(IDIR_OPENVPN_EASY_RSA)/usr/sbin $(IDIR_OPENVPN_EASY_RSA)/etc/easy-rsa
- $(CP) $(PKG_BUILD_DIR)/easy-rsa/2.0/{build-*,clean-all,inherit-inter,list-crl,pkitool,revoke-full,sign-req} $(IDIR_OPENVPN_EASY_RSA)/usr/sbin
- install -m 0644 $(PKG_BUILD_DIR)/easy-rsa/2.0/openssl.cnf $(IDIR_OPENVPN_EASY_RSA)/etc/easy-rsa/openssl.cnf
- install -m 0644 $(PKG_BUILD_DIR)/easy-rsa/2.0/vars $(IDIR_OPENVPN_EASY_RSA)/etc/easy-rsa/vars
- $(IPKG_BUILD) $(IDIR_OPENVPN_EASY_RSA) $(PACKAGE_DIR)
diff --git a/openwrt/package/openvpn/ipkg/openvpn-easy-rsa.control b/openwrt/package/openvpn/ipkg/openvpn-easy-rsa.control
deleted file mode 100644
index 6ce25a4..0000000
--- a/openwrt/package/openvpn/ipkg/openvpn-easy-rsa.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: openvpn-easy-rsa
-Priority: optional
-Section: net
-Description: collection of shell scripts to manage a simple CA infrastructure
-Depends: openssl-util
diff --git a/openwrt/package/openvpn/ipkg/openvpn.control b/openwrt/package/openvpn/ipkg/openvpn.control
deleted file mode 100644
index 50f06ba..0000000
--- a/openwrt/package/openvpn/ipkg/openvpn.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: openvpn
-Priority: optional
-Section: net
-Description: Open Source VPN solution using SSL
diff --git a/openwrt/package/openvpn/patches/easy-rsa.patch b/openwrt/package/openvpn/patches/easy-rsa.patch
deleted file mode 100644
index c5332b7..0000000
--- a/openwrt/package/openvpn/patches/easy-rsa.patch
+++ /dev/null
@@ -1,159 +0,0 @@
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-ca openvpn-2.0.7/easy-rsa/2.0/build-ca
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-ca 2005-11-02 19:42:38.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-ca 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- #
- # Build a root certificate
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-dh openvpn-2.0.7/easy-rsa/2.0/build-dh
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-dh 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-dh 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-+
-+. /etc/easy-rsa/vars
-
- # Build Diffie-Hellman parameters for the server side
- # of an SSL/TLS connection.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-inter openvpn-2.0.7/easy-rsa/2.0/build-inter
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-inter 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-inter 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Make an intermediate CA certificate/private key pair using a locally generated
- # root certificate.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key openvpn-2.0.7/easy-rsa/2.0/build-key
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-key 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-key 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Make a certificate/private key pair using a locally generated
- # root certificate.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pass openvpn-2.0.7/easy-rsa/2.0/build-key-pass
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pass 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-key-pass 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Similar to build-key, but protect the private key
- # with a password.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pkcs12 openvpn-2.0.7/easy-rsa/2.0/build-key-pkcs12
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pkcs12 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-key-pkcs12 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Make a certificate/private key pair using a locally generated
- # root certificate and convert it to a PKCS #12 file including the
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key-server openvpn-2.0.7/easy-rsa/2.0/build-key-server
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-key-server 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-key-server 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Make a certificate/private key pair using a locally generated
- # root certificate.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-req openvpn-2.0.7/easy-rsa/2.0/build-req
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-req 2005-11-02 19:42:38.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-req 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Build a certificate signing request and private key. Use this
- # when your root certificate and key is not available locally.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-req-pass openvpn-2.0.7/easy-rsa/2.0/build-req-pass
---- openvpn-2.0.7.orig/easy-rsa/2.0/build-req-pass 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/build-req-pass 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Like build-req, but protect your private key
- # with a password.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/clean-all openvpn-2.0.7/easy-rsa/2.0/clean-all
---- openvpn-2.0.7.orig/easy-rsa/2.0/clean-all 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/clean-all 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-+
-+. /etc/easy-rsa/vars
-
- # Initialize the $KEY_DIR directory.
- # Note that this script does a
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/inherit-inter openvpn-2.0.7/easy-rsa/2.0/inherit-inter
---- openvpn-2.0.7.orig/easy-rsa/2.0/inherit-inter 2005-11-02 19:42:38.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/inherit-inter 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-+
-+. /etc/easy-rsa/vars
-
- # Build a new PKI which is rooted on an intermediate certificate generated
- # by ./build-inter or ./pkitool --inter from a parent PKI. The new PKI should
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/list-crl openvpn-2.0.7/easy-rsa/2.0/list-crl
---- openvpn-2.0.7.orig/easy-rsa/2.0/list-crl 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/list-crl 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-+
-+. /etc/easy-rsa/vars
-
- # list revoked certificates
-
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/pkitool openvpn-2.0.7/easy-rsa/2.0/pkitool
---- openvpn-2.0.7.orig/easy-rsa/2.0/pkitool 2005-11-02 19:42:38.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/pkitool 2006-05-09 17:47:40.000000000 +0200
-@@ -1,5 +1,7 @@
- #!/bin/sh
-
-+. /etc/easy-rsa/vars
-+
- # OpenVPN -- An application to securely tunnel IP networks
- # over a single TCP/UDP port, with support for SSL/TLS-based
- # session authentication and key exchange,
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/revoke-full openvpn-2.0.7/easy-rsa/2.0/revoke-full
---- openvpn-2.0.7.orig/easy-rsa/2.0/revoke-full 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/revoke-full 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,6 @@
--#!/bin/bash
-+#!/bin/sh
-+
-+. /etc/easy-rsa/vars
-
- # revoke a certificate, regenerate CRL,
- # and verify revocation
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/sign-req openvpn-2.0.7/easy-rsa/2.0/sign-req
---- openvpn-2.0.7.orig/easy-rsa/2.0/sign-req 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/sign-req 2006-05-09 17:47:40.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Sign a certificate signing request (a .csr file)
- # with a local root certificate and key.
-diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/vars openvpn-2.0.7/easy-rsa/2.0/vars
---- openvpn-2.0.7.orig/easy-rsa/2.0/vars 2005-11-02 19:42:39.000000000 +0100
-+++ openvpn-2.0.7/easy-rsa/2.0/vars 2006-05-09 17:47:40.000000000 +0200
-@@ -12,7 +12,7 @@
- # This variable should point to
- # the top level of the easy-rsa
- # tree.
--export EASY_RSA="`pwd`"
-+export EASY_RSA="/etc/easy-rsa"
-
- # This variable should point to
- # the openssl.cnf file included