summaryrefslogtreecommitdiff
path: root/openwrt/package/pcre
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/pcre')
-rw-r--r--openwrt/package/pcre/Config.in15
-rw-r--r--openwrt/package/pcre/Makefile92
-rw-r--r--openwrt/package/pcre/ipkg/libpcre.control4
-rw-r--r--openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch24
-rw-r--r--openwrt/package/pcre/patches/750-pcre_config_cross.patch27
5 files changed, 0 insertions, 162 deletions
diff --git a/openwrt/package/pcre/Config.in b/openwrt/package/pcre/Config.in
deleted file mode 100644
index 7bb2de6..0000000
--- a/openwrt/package/pcre/Config.in
+++ /dev/null
@@ -1,15 +0,0 @@
-config BR2_COMPILE_PCRE
- tristate
- default n
- depends BR2_PACKAGE_LIBPCRE
-
-config BR2_PACKAGE_LIBPCRE
- prompt "libpcre........................... A Perl Compatible Regular Expression library"
- tristate
- default m if CONFIG_DEVEL
- select BR2_COMPILE_PCRE
- help
- A Perl Compatible Regular Expression library
-
- http://www.pcre.org/
-
diff --git a/openwrt/package/pcre/Makefile b/openwrt/package/pcre/Makefile
deleted file mode 100644
index 3cd0304..0000000
--- a/openwrt/package/pcre/Makefile
+++ /dev/null
@@ -1,92 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pcre
-PKG_VERSION:=5.0
-PKG_RELEASE:=3
-PKG_MD5SUM:=813850808894d99fb5b1c41ec6335d4f
-
-PKG_SOURCE_URL:=@SF/pcre
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBPCRE,libpcre,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --enable-static \
- --enable-utf8 \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C "$(PKG_BUILD_DIR)" \
- CC_FOR_BUILD="$(HOSTCC)" \
- LINK_FOR_BUILD="$(HOSTCC)" \
- CFLAGS_FOR_BUILD="" \
- dftables
- $(MAKE) -C "$(PKG_BUILD_DIR)" \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_LIBPCRE):
- install -d -m0755 $(IDIR_LIBPCRE)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.so.* $(IDIR_LIBPCRE)/usr/lib/
- $(RSTRIP) $(IDIR_LIBPCRE)
- $(IPKG_BUILD) $(IDIR_LIBPCRE) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libpcre.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/pcre-config $(STAGING_DIR)/usr/bin/
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/pcre{,posix}.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcre{,posix}.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libpcre.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/bin/pcre-config \
- $(STAGING_DIR)/usr/include/pcre{,posix}.h \
- $(STAGING_DIR)/usr/lib/libpcre{,posix}.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/pcre/ipkg/libpcre.control b/openwrt/package/pcre/ipkg/libpcre.control
deleted file mode 100644
index 797453e..0000000
--- a/openwrt/package/pcre/ipkg/libpcre.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: libpcre
-Priority: optional
-Section: libs
-Description: a Perl Compatible Regular Expression library
diff --git a/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch b/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch
deleted file mode 100644
index 2d14b89..0000000
--- a/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ruN pcre-5.0-old/Makefile.in pcre-5.0-new/Makefile.in
---- pcre-5.0-old/Makefile.in 2004-09-13 16:20:00.000000000 +0200
-+++ pcre-5.0-new/Makefile.in 2006-03-15 08:28:12.000000000 +0100
-@@ -63,6 +63,7 @@
- CC = @CC@
- CFLAGS = @CFLAGS@
- CPPFLAGS = @CPPFLAGS@
-+LDFLAGS = @LDFLAGS@
-
- CC_FOR_BUILD = @CC_FOR_BUILD@
- CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
-@@ -84,10 +85,10 @@
- # to do one or the other or both by ./configure.
-
- LIBTOOL = @LIBTOOL@
--LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
-+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(CPPFLAGS) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
- @ON_WINDOWS@LINK = $(CC) $(CFLAGS) -I. -I$(top_srcdir) -L.libs
- @NOT_ON_WINDOWS@LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
--LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
-+LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir) $(LDFLAGS)
- LINK_FOR_BUILD = $(LIBTOOL) --mode=link $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -I. -I$(top_srcdir)
-
- # These are the version numbers for the shared libraries
diff --git a/openwrt/package/pcre/patches/750-pcre_config_cross.patch b/openwrt/package/pcre/patches/750-pcre_config_cross.patch
deleted file mode 100644
index c61a7f5..0000000
--- a/openwrt/package/pcre/patches/750-pcre_config_cross.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ruN pcre-5.0-old/pcre-config.in pcre-5.0-new/pcre-config.in
---- pcre-5.0-old/pcre-config.in 2004-09-13 16:20:00.000000000 +0200
-+++ pcre-5.0-new/pcre-config.in 2005-09-04 16:34:39.000000000 +0200
-@@ -18,6 +18,10 @@
- libR=" -R@libdir@"
- ;;
- esac
-+libS=
-+if test @libdir@ != /usr/lib ; then
-+ libS=-L@libdir@
-+fi
-
- while test $# -gt 0; do
- case "$1" in
-@@ -52,10 +56,10 @@
- echo $includes
- ;;
- --libs-posix)
-- echo -L@libdir@$libR -lpcreposix -lpcre
-+ echo $libS$libR -lpcreposix -lpcre
- ;;
- --libs)
-- echo -L@libdir@$libR -lpcre
-+ echo $libS$libR -lpcre
- ;;
- *)
- echo "${usage}" 1>&2