summaryrefslogtreecommitdiff
path: root/openwrt/package/postgresql
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/postgresql')
-rw-r--r--openwrt/package/postgresql/Config.in61
-rw-r--r--openwrt/package/postgresql/Makefile127
-rw-r--r--openwrt/package/postgresql/ipkg/libpq.control4
-rw-r--r--openwrt/package/postgresql/ipkg/pgsql-cli.control5
-rw-r--r--openwrt/package/postgresql/patches/100-debian-12asmconstraints21
-rw-r--r--openwrt/package/postgresql/patches/101-debian-27dbf2pg-textfield14
-rw-r--r--openwrt/package/postgresql/patches/102-debian-30libpq33
-rw-r--r--openwrt/package/postgresql/patches/750-configure-honor-cppflags.patch10
8 files changed, 0 insertions, 275 deletions
diff --git a/openwrt/package/postgresql/Config.in b/openwrt/package/postgresql/Config.in
deleted file mode 100644
index 776dccc..0000000
--- a/openwrt/package/postgresql/Config.in
+++ /dev/null
@@ -1,61 +0,0 @@
-config BR2_COMPILE_POSTGRESQL
- tristate
- default n
- depends BR2_PACKAGE_LIBPQ
-
-config BR2_PACKAGE_LIBPQ
- prompt "libpq............................. PostgreSQL client library"
- tristate
- default m if CONFIG_DEVEL
- select BR2_COMPILE_POSTGRESQL
- help
- PostgreSQL is an object-relational database management system (ORDBMS)
- based on POSTGRES, Version 4.2, developed at the University of
- California at Berkeley Computer Science Department. POSTGRES pioneered
- many concepts that only became available in some commercial database
- systems much later.
-
- PostgreSQL is an open-source descendant of this original Berkeley code.
- It supports SQL92 and SQL99 and offers many modern features:
-
- * complex queries
- * foreign keys
- * triggers
- * views
- * transactional integrity
- * multiversion concurrency control
-
- http://www.postgresql.org/
-
- This package contains the shared client library, needed by other programs.
-
-config BR2_PACKAGE_PGSQL_CLI
- prompt "pgsql-cli....................... Command Line Interface (CLI) to PostgreSQL databases"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_LIBPQ
- help
- PostgreSQL is an object-relational database management system (ORDBMS)
- based on POSTGRES, Version 4.2, developed at the University of
- California at Berkeley Computer Science Department. POSTGRES pioneered
- many concepts that only became available in some commercial database
- systems much later.
-
- PostgreSQL is an open-source descendant of this original Berkeley code.
- It supports SQL92 and SQL99 and offers many modern features:
-
- * complex queries
- * foreign keys
- * triggers
- * views
- * transactional integrity
- * multiversion concurrency control
-
- http://www.postgresql.org/
-
- This package contains a terminal-based front-end to PostgreSQL. It enables
- you to type in queries interactively, issue them to PostgreSQL, and see the
- query results. Alternatively, input can be from a file. In addition, it
- provides a number of meta-commands and various shell-like features to
- facilitate writing scripts and automating a wide variety of tasks.
-
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
deleted file mode 100644
index 2cb3f6d..0000000
--- a/openwrt/package/postgresql/Makefile
+++ /dev/null
@@ -1,127 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=postgresql
-PKG_VERSION:=7.4.9
-PKG_RELEASE:=1
-PKG_MD5SUM:=d7cf0f0a0e1dda19268f55cb1e124c77
-
-PKG_SOURCE_URL:=\
- ftp://ftp3.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/ \
- ftp://ftp.br.postgresql.org/pub/PostgreSQL/source/v$(PKG_VERSION)/ \
- ftp://ftp.au.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/ \
- ftp://ftp.tw.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBPQ,libpq,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,PGSQL_CLI,pgsql-cli,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-# ./configure advertise "--infodir", but does not support it, replaced with "--docdir"
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
- CPPFLAGS="$$CPPFLAGS -I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --docdir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared \
- --enable-static \
- --disable-integer-datetimes \
- --disable-rpath \
- --without-java \
- --without-krb4 \
- --without-krb5 \
- --without-openssl \
- --without-pam \
- --without-perl \
- --without-python \
- --without-readline \
- --without-rendezvous \
- --without-tcl \
- --without-tk \
- --with-zlib="yes" \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C "$(PKG_BUILD_DIR)/src/include" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- $(MAKE) -C "$(PKG_BUILD_DIR)/src/interfaces/libpq" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- $(MAKE) -C "$(PKG_BUILD_DIR)/src/bin/pg_config" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- includedir="$(STAGING_DIR)/usr/include" \
- libdir="$(STAGING_DIR)/usr/lib" \
- all install
- $(MAKE) -C "$(PKG_BUILD_DIR)/src/bin/psql" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_LIBPQ):
- install -d -m0755 $(IDIR_LIBPQ)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpq.so.* $(IDIR_LIBPQ)/usr/lib/
- $(RSTRIP) $(IDIR_LIBPQ)
- $(IPKG_BUILD) $(IDIR_LIBPQ) $(PACKAGE_DIR)
-
-$(IPKG_PGSQL_CLI):
- install -d -m0755 $(IDIR_PGSQL_CLI)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/psql $(IDIR_PGSQL_CLI)/usr/bin/
- $(RSTRIP) $(IDIR_PGSQL_CLI)
- $(IPKG_BUILD) $(IDIR_PGSQL_CLI) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/pg_config $(STAGING_DIR)/usr/bin/
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpq.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libpq.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/bin/pg_config \
- $(STAGING_DIR)/usr/include/libpq \
- $(STAGING_DIR)/usr/include/libpq-fe.h \
- $(STAGING_DIR)/usr/include/pg_config.h \
- $(STAGING_DIR)/usr/include/postgres_ext.h \
- $(STAGING_DIR)/usr/include/postgresql \
- $(STAGING_DIR)/usr/lib/libpq.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/postgresql/ipkg/libpq.control b/openwrt/package/postgresql/ipkg/libpq.control
deleted file mode 100644
index ff669c6..0000000
--- a/openwrt/package/postgresql/ipkg/libpq.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: libpq
-Priority: optional
-Section: libs
-Description: PostgreSQL client library
diff --git a/openwrt/package/postgresql/ipkg/pgsql-cli.control b/openwrt/package/postgresql/ipkg/pgsql-cli.control
deleted file mode 100644
index 4ce03e4..0000000
--- a/openwrt/package/postgresql/ipkg/pgsql-cli.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: pgsql-cli
-Priority: optional
-Section: libs
-Description: Command Line Interface (CLI) to PostgreSQL databases
-Depends: libpq
diff --git a/openwrt/package/postgresql/patches/100-debian-12asmconstraints b/openwrt/package/postgresql/patches/100-debian-12asmconstraints
deleted file mode 100644
index f43eedc..0000000
--- a/openwrt/package/postgresql/patches/100-debian-12asmconstraints
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN postgresql-7.4.7-old/src/include/storage/s_lock.h postgresql-7.4.7/src/include/storage/s_lock.h
---- postgresql-7.4.7-old/src/include/storage/s_lock.h 2004-06-15 16:09:30.000000000 +0200
-+++ postgresql-7.4.7/src/include/storage/s_lock.h 2004-06-15 16:19:02.000000000 +0200
-@@ -125,7 +125,7 @@
- __asm__ __volatile__(
- " xchg4 %0=%1,%2 \n"
- : "=r"(ret), "=m"(*lock)
--: "r"(1), "1"(*lock)
-+: "r"(1), "m"(*lock)
- : "memory");
-
- return (int) ret;
-@@ -294,7 +294,7 @@
- " tas %1 \n"
- " sne %0 \n"
- : "=d"(rv), "=m"(*lock)
--: "1"(*lock)
-+: "m"(*lock)
- : "cc");
-
- return rv;
diff --git a/openwrt/package/postgresql/patches/101-debian-27dbf2pg-textfield b/openwrt/package/postgresql/patches/101-debian-27dbf2pg-textfield
deleted file mode 100644
index a450771..0000000
--- a/openwrt/package/postgresql/patches/101-debian-27dbf2pg-textfield
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ruN postgresql-7.4.7-old/contrib/dbase/dbf2pg.c postgresql-7.4.7/contrib/dbase/dbf2pg.c
---- postgresql-7.4.7-old/contrib/dbase/dbf2pg.c 2004-10-31 20:09:10.923855000 +0100
-+++ postgresql-7.4.7/contrib/dbase/dbf2pg.c 2004-10-31 20:11:24.676521696 +0100
-@@ -324,6 +324,10 @@
- case 'L':
- strcat(query, " char");
- break;
-+
-+ case 'M':
-+ strcat(query, " text");
-+ break;
- }
- }
-
diff --git a/openwrt/package/postgresql/patches/102-debian-30libpq b/openwrt/package/postgresql/patches/102-debian-30libpq
deleted file mode 100644
index 245b97f..0000000
--- a/openwrt/package/postgresql/patches/102-debian-30libpq
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -ruN postgresql-7.4.7-old/src/interfaces/libpq/Makefile postgresql-7.4.7/src/interfaces/libpq/Makefile
---- postgresql-7.4.7-old/src/interfaces/libpq/Makefile 2003-08-23 05:21:59.000000000 +0100
-+++ postgresql-7.4.7/src/interfaces/libpq/Makefile 2003-08-29 18:35:25.000000000 +0100
-@@ -32,7 +32,7 @@
- SHLIB_LINK += $(filter -lcrypt -ldes -lkrb -lcom_err -lcrypto -lk5crypto -lkrb5 -lssl -lsocket -lnsl -lresolv -lintl, $(LIBS)) $(THREAD_LIBS)
-
-
--all: all-lib
-+all: all-lib libpq3-config
-
- # Shared library stuff
- include $(top_srcdir)/src/Makefile.shlib
-@@ -58,6 +58,8 @@
- encnames.c wchar.c : % : $(backend_src)/utils/mb/%
- rm -f $@ && $(LN_S) $< .
-
-+libpq3-config:
-+ sed -e "s|%LIBRARIES%|$(SHLIB_LINK)|" <libpq3-config.in | sed "s/-L[^ ]\+ //" >libpq3-config
-
- install: all installdirs install-lib
- $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
-@@ -73,3 +75,4 @@
-
- clean distclean maintainer-clean: clean-lib
- rm -f $(OBJS) crypt.c getaddrinfo.c inet_aton.c snprintf.c strerror.c path.c thread.c dllist.c md5.c ip.c encnames.c wchar.c
-+ rm -f libpq3-config
-diff -ruN postgresql-7.4.7-old/src/interfaces/libpq/libpq3-config.in postgresql-7.4.7/src/interfaces/libpq/libpq3-config.in
---- postgresql-7.4.7-old/src/interfaces/libpq/libpq3-config.in 1970-01-01 01:00:00.000000000 +0100
-+++ postgresql-7.4.7/src/interfaces/libpq/libpq3-config.in 2003-08-29 18:34:25.000000000 +0100
-@@ -0,0 +1,3 @@
-+#!/bin/bash
-+
-+echo %LIBRARIES%
diff --git a/openwrt/package/postgresql/patches/750-configure-honor-cppflags.patch b/openwrt/package/postgresql/patches/750-configure-honor-cppflags.patch
deleted file mode 100644
index 897c6c0..0000000
--- a/openwrt/package/postgresql/patches/750-configure-honor-cppflags.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -ruN postgresql-7.4.6-old/src/template/linux postgresql-7.4.6-new/src/template/linux
---- postgresql-7.4.6-old/src/template/linux 2003-10-09 18:52:45.000000000 +0200
-+++ postgresql-7.4.6-new/src/template/linux 2005-04-13 03:12:49.000000000 +0200
-@@ -1,5 +1,5 @@
- # Force _GNU_SOURCE on; plperl is broken with Perl 5.8.0 otherwise
--CPPFLAGS="-D_GNU_SOURCE"
-+CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
-
- THREAD_SUPPORT=yes
- NEED_REENTRANT_FUNCS=yes # Debian kernel 2.2 2003-09-27