summaryrefslogtreecommitdiff
path: root/openwrt/package/pptp
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/pptp')
-rw-r--r--openwrt/package/pptp/Config.in11
-rw-r--r--openwrt/package/pptp/Makefile38
-rw-r--r--openwrt/package/pptp/files/ifup.pptp45
-rw-r--r--openwrt/package/pptp/files/options.pptp6
-rw-r--r--openwrt/package/pptp/ipkg/pptp.conffiles1
-rw-r--r--openwrt/package/pptp/ipkg/pptp.control5
6 files changed, 0 insertions, 106 deletions
diff --git a/openwrt/package/pptp/Config.in b/openwrt/package/pptp/Config.in
deleted file mode 100644
index 88da237..0000000
--- a/openwrt/package/pptp/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_PPTP
- prompt "pptp.............................. PPTP (Point-to-Point Tunneling Protocol) client"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_KMOD_GRE
- select BR2_PACKAGE_PPP
- help
- A Point-to-Point Tunneling Protocol Client
-
- http://pptpclient.sourceforge.net/
-
diff --git a/openwrt/package/pptp/Makefile b/openwrt/package/pptp/Makefile
deleted file mode 100644
index 870341c..0000000
--- a/openwrt/package/pptp/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pptp
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=3
-PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
-
-PKG_SOURCE_URL:=@SF/pptpclient
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PPTP,pptp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- CFLAGS="$(TARGET_CFLAGS)" \
- all
- touch $@
-
-$(IPKG_PPTP):
- install -d -m0755 $(IDIR_PPTP)/sbin
- install -m0755 ./files/ifup.pptp $(IDIR_PPTP)/sbin/ifup.pptp
- install -d -m0755 $(IDIR_PPTP)/etc/ppp
- install -m0644 ./files/options.pptp $(IDIR_PPTP)/etc/ppp/
- install -d -m0755 $(IDIR_PPTP)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/pptp $(IDIR_PPTP)/usr/sbin/
- $(RSTRIP) $(IDIR_PPTP)
- $(IPKG_BUILD) $(IDIR_PPTP) $(PACKAGE_DIR)
diff --git a/openwrt/package/pptp/files/ifup.pptp b/openwrt/package/pptp/files/ifup.pptp
deleted file mode 100644
index f401a36..0000000
--- a/openwrt/package/pptp/files/ifup.pptp
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh
-[ $# = 0 ] && { echo " $0 <group>"; exit; }
-. /etc/config/network
-type=$1
-
-eval "proto=\"\${${type}_proto}\""
-[ "$proto" = "pptp" ] || {
- echo "$0: ${type}_proto isn't pptp"
- exit
-}
-
-mkdir -p /var/lock
-
-for module in slhc ppp_generic ppp_async ip_gre; do
- /sbin/insmod $module 2>&- >&-
-done
-
-KEEPALIVE=${ppp_redialperiod:+lcp-echo-interval $ppp_redialperiod lcp-echo-failure 5}
-case "$ppp_demand" in
- on|1|enabled)
- DEMAND=${ppp_idletime:+demand idle $ppp_idletime}
- [ -f /etc/ppp/filter ] && DEMAND=${DEMAND:+precompiled-active-filter /etc/ppp/filter $DEMAND}
- ;;
- *) DEMAND="persist";;
-esac
-MTU=${ppp_mtu:-1452}
-
-[ "$pptp_proto" = "static" ] || pptp_proto="dhcp"
-do_ifup $pptp_proto $type
-
-/usr/sbin/pppd \
- pty "/usr/sbin/pptp $pptp_server_ip --loglevel 0 --nolaunchpppd" \
- file /etc/ppp/options.pptp \
- connect /bin/true \
- usepeerdns \
- defaultroute \
- replacedefaultroute \
- linkname "$type" \
- ipparam "$type" \
- user "$ppp_username" \
- password "$ppp_passwd" \
- mtu $MTU mru $MTU \
- $DEMAND \
- $KEEPALIVE
-
diff --git a/openwrt/package/pptp/files/options.pptp b/openwrt/package/pptp/files/options.pptp
deleted file mode 100644
index c520de7..0000000
--- a/openwrt/package/pptp/files/options.pptp
+++ /dev/null
@@ -1,6 +0,0 @@
-lock
-noauth
-nobsdcomp
-nodeflate
-idle 0
-defaultroute
diff --git a/openwrt/package/pptp/ipkg/pptp.conffiles b/openwrt/package/pptp/ipkg/pptp.conffiles
deleted file mode 100644
index 136db31..0000000
--- a/openwrt/package/pptp/ipkg/pptp.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/ppp/options.pptp \ No newline at end of file
diff --git a/openwrt/package/pptp/ipkg/pptp.control b/openwrt/package/pptp/ipkg/pptp.control
deleted file mode 100644
index e582c62..0000000
--- a/openwrt/package/pptp/ipkg/pptp.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: pptp
-Priority: optional
-Section: net
-Description: a Point-to-Point Tunneling Protocol (PPTP) client
-Depends: ppp, kmod-gre