summaryrefslogtreecommitdiff
path: root/openwrt/package/procmail
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/procmail')
-rw-r--r--openwrt/package/procmail/Config.in11
-rw-r--r--openwrt/package/procmail/Makefile31
-rw-r--r--openwrt/package/procmail/ipkg/procmail.control4
-rw-r--r--openwrt/package/procmail/patches/promail_openwrt.patch51
4 files changed, 0 insertions, 97 deletions
diff --git a/openwrt/package/procmail/Config.in b/openwrt/package/procmail/Config.in
deleted file mode 100644
index 548b8e6..0000000
--- a/openwrt/package/procmail/Config.in
+++ /dev/null
@@ -1,11 +0,0 @@
-config BR2_PACKAGE_PROCMAIL
- prompt "procmail.......................... mail processing tool"
- tristate
- default n
- help
- Procmail is able to process and classify incoming mail into
- different mail boxes.
-
- Very useful in conjunction with mutt.
-
- http://www.procmail.org
diff --git a/openwrt/package/procmail/Makefile b/openwrt/package/procmail/Makefile
deleted file mode 100644
index ace0a0b..0000000
--- a/openwrt/package/procmail/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=procmail
-PKG_VERSION:=3.22
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=http://www.procmail.org/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=1678ea99b973eb77eda4ecf6acae53f1
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PROCMAIL,procmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)/src -f ../Makefile.openwrt \
- CC=$(TARGET_CC)
-
- touch $@
-
-$(IPKG_PROCMAIL):
- mkdir -p $(IDIR_PROCMAIL)/usr/bin
- $(CP) $(PKG_BUILD_DIR)/src/procmail $(IDIR_PROCMAIL)/usr/bin/
- $(CP) $(PKG_BUILD_DIR)/src/formail $(IDIR_PROCMAIL)/usr/bin/
- $(RSTRIP) $(IDIR_PROCMAIL)
- $(IPKG_BUILD) $(IDIR_PROCMAIL) $(PACKAGE_DIR)
diff --git a/openwrt/package/procmail/ipkg/procmail.control b/openwrt/package/procmail/ipkg/procmail.control
deleted file mode 100644
index 6a87f9f..0000000
--- a/openwrt/package/procmail/ipkg/procmail.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: procmail
-Priority: optional
-Section: text
-Description: Mail processing tool
diff --git a/openwrt/package/procmail/patches/promail_openwrt.patch b/openwrt/package/procmail/patches/promail_openwrt.patch
deleted file mode 100644
index c33d826..0000000
--- a/openwrt/package/procmail/patches/promail_openwrt.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-This patch is required to make procmail cross compile - it tries to run some automatic tests which
-obviously do not work in a cross compiled environment.
-
-
-diff -Naur procmail-3.22_orig/autoconf.h procmail-3.22/autoconf.h
---- procmail-3.22_orig/autoconf.h 1970-01-01 10:00:00.000000000 +1000
-+++ procmail-3.22/autoconf.h 2006-03-23 12:15:36.000000000 +1100
-@@ -0,0 +1,21 @@
-+/* This file was automagically generated by autoconf */
-+
-+/* 5 moves in 64 steps of size 16384 when reallocing */
-+#define NOpw_class
-+#define NOstrlcat
-+#define NOsetrgid
-+#define MAX_argc 7588
-+/* Your system's strstr() is 1.12 times FASTER than my C-routine */
-+#define UDP_protocolno 17
-+#define BIFF_serviceport "512"
-+#define IP_localhost {127,0,0,1}
-+#define MAILSPOOLDIR "/var/spool/mail/"
-+#define SENDMAIL "/usr/sbin/sendmail"
-+#define CF_no_procmail_yet
-+#define buggy_SENDMAIL
-+#define defPATH "PATH=$HOME/bin:/bin:/usr/bin:/usr/local/bin:/usr/bin/X11"
-+#define defSPATH "PATH=/bin:/usr/bin:/usr/local/bin:/usr/bin/X11"
-+#define PM_VERSION "3.22"
-+/* Hotwire LOCKINGTEST=100 */
-+/* Procmail will lock via: dotlocking, fcntl() */
-+/* autoconf completed */
-diff -Naur procmail-3.22_orig/Makefile.openwrt procmail-3.22/Makefile.openwrt
---- procmail-3.22_orig/Makefile.openwrt 1970-01-01 10:00:00.000000000 +1000
-+++ procmail-3.22/Makefile.openwrt 2006-03-23 12:15:36.000000000 +1100
-@@ -0,0 +1,18 @@
-+PM_OBJ=cstdio.o common.o exopen.o goodies.o locking.o \
-+ mailfold.o foldinfo.o misc.o pipes.o regexp.o robust.o \
-+ sublib.o acommon.o mcommon.o lastdirsep.o authenticate.o \
-+ lmtp.o memblk.o variables.o from.o comsat.o
-+
-+FM_OBJ=common.o fields.o formisc.o sublib.o ecommon.o \
-+ acommon.o
-+
-+LDFLAGS = -lm -lnsl -ldl -lc
-+CFLAGS = -Os -DPROCMAIL
-+
-+all: procmail formail
-+
-+procmail: procmail.o $(PM_OBJ)
-+ $(CC) $(CFLAGS) $@.o $(PM_OBJ) -o $@ $(LDFLAGS)
-+
-+formail: formail.o $(FM_OBJ)
-+ $(CC) $(CFLAGS) $@.o $(FM_OBJ) -o $@ $(LDFLAGS)