summaryrefslogtreecommitdiff
path: root/openwrt/package/radvd
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/radvd')
-rw-r--r--openwrt/package/radvd/Config.in10
-rw-r--r--openwrt/package/radvd/Makefile70
-rw-r--r--openwrt/package/radvd/files/radvd.conf22
-rw-r--r--openwrt/package/radvd/files/radvd.init24
-rw-r--r--openwrt/package/radvd/ipkg/radvd.conffiles1
-rw-r--r--openwrt/package/radvd/ipkg/radvd.control5
-rw-r--r--openwrt/package/radvd/patches/no-libfl.patch12
7 files changed, 0 insertions, 144 deletions
diff --git a/openwrt/package/radvd/Config.in b/openwrt/package/radvd/Config.in
deleted file mode 100644
index 46bc355..0000000
--- a/openwrt/package/radvd/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_RADVD
- prompt "radvd............................. IPv6 Routing Advertisement Daemon"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_KMOD_IPV6
- help
- Routing Advertisement Daemon for IPv6
-
- http://v6web.litech.org/radvd/
-
diff --git a/openwrt/package/radvd/Makefile b/openwrt/package/radvd/Makefile
deleted file mode 100644
index e31264b..0000000
--- a/openwrt/package/radvd/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=radvd
-PKG_VERSION:=0.7.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=56ce3f8cbf5966a0d531c21813320423
-
-PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
- http://download.sourcemage.org/mirror
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,RADVD,radvd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --with-configfile=/etc/radvd.conf \
- --with-logfile=/var/log/radvd.log \
- --with-pidfile=/var/run/radvd.pid \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- radvd_LDADD=""
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $@
-
-$(IPKG_RADVD):
- install -d -m0755 $(IDIR_RADVD)/etc
- install -m0644 ./files/radvd.conf $(IDIR_RADVD)/etc/radvd.conf
- install -d -m0755 $(IDIR_RADVD)/etc/init.d
- install -m0755 ./files/radvd.init $(IDIR_RADVD)/etc/init.d/S51radvd
- install -d -m0755 $(IDIR_RADVD)/usr/sbin
- install -m 755 $(PKG_INSTALL_DIR)/usr/sbin/radvd $(IDIR_RADVD)/usr/sbin/
- install -m 755 $(PKG_INSTALL_DIR)/usr/sbin/radvdump $(IDIR_RADVD)/usr/sbin/
- $(RSTRIP) $(IDIR_RADVD)
- $(IPKG_BUILD) $(IDIR_RADVD) $(PACKAGE_DIR)
diff --git a/openwrt/package/radvd/files/radvd.conf b/openwrt/package/radvd/files/radvd.conf
deleted file mode 100644
index 06d8357..0000000
--- a/openwrt/package/radvd/files/radvd.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-# For more examples, see the radvd documentation.
-
-interface br0
-{
- AdvSendAdvert off;
-
-#
-# Disable Mobile IPv6 support
-#
- AdvHomeAgentFlag off;
-
-#
-# example of a standard prefix
-#
- prefix fec0:0:0:1::/64
- {
- AdvOnLink on;
- AdvAutonomous on;
- AdvRouterAddr off;
- };
-
-};
diff --git a/openwrt/package/radvd/files/radvd.init b/openwrt/package/radvd/files/radvd.init
deleted file mode 100644
index 2d9e500..0000000
--- a/openwrt/package/radvd/files/radvd.init
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- start)
- echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
- mkdir -p /var/log
- mkdir -p /var/run
- /usr/sbin/radvd
- ;;
-
- stop)
- killall radvd
- echo 0 > /proc/sys/net/ipv6/conf/all/forwarding
- ;;
-
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart}"
- exit 1
- ;;
-esac
diff --git a/openwrt/package/radvd/ipkg/radvd.conffiles b/openwrt/package/radvd/ipkg/radvd.conffiles
deleted file mode 100644
index a1418c0..0000000
--- a/openwrt/package/radvd/ipkg/radvd.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/radvd.conf
diff --git a/openwrt/package/radvd/ipkg/radvd.control b/openwrt/package/radvd/ipkg/radvd.control
deleted file mode 100644
index 67df96e..0000000
--- a/openwrt/package/radvd/ipkg/radvd.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: radvd
-Priority: optional
-Section: net
-Depends: kmod-ipv6
-Description: Routing Advertisement Daemon for IPv6
diff --git a/openwrt/package/radvd/patches/no-libfl.patch b/openwrt/package/radvd/patches/no-libfl.patch
deleted file mode 100644
index e17a127..0000000
--- a/openwrt/package/radvd/patches/no-libfl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN radvd-0.7.3.old/scanner.l radvd-0.7.3/scanner.l
---- radvd-0.7.3.old/scanner.l 2004-10-26 07:30:34.000000000 +0200
-+++ radvd-0.7.3/scanner.l 2005-04-05 00:01:42.000000000 +0200
-@@ -21,6 +21,8 @@
-
- extern char *conf_file;
-
-+int yywrap(void) { return 1; }
-+
- int num_lines = 1;
- %}
-