summaryrefslogtreecommitdiff
path: root/openwrt/package/serdisplib
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/serdisplib')
-rw-r--r--openwrt/package/serdisplib/Config.in10
-rw-r--r--openwrt/package/serdisplib/Makefile82
-rw-r--r--openwrt/package/serdisplib/ipkg/serdisplib.control4
-rw-r--r--openwrt/package/serdisplib/patches/100-io.patch19
-rw-r--r--openwrt/package/serdisplib/patches/101-test_shared.patch14
5 files changed, 0 insertions, 129 deletions
diff --git a/openwrt/package/serdisplib/Config.in b/openwrt/package/serdisplib/Config.in
deleted file mode 100644
index c5181a5..0000000
--- a/openwrt/package/serdisplib/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_SERDISPLIB
- prompt "serdisplib........................ a library for controlling displays"
- tristate
- default m if CONFIG_DEVEL
- help
- serdisplib is a library to drive serial and parallel displays
- with built-in controllers.
-
- http://serdisplib.sourceforge.net/
-
diff --git a/openwrt/package/serdisplib/Makefile b/openwrt/package/serdisplib/Makefile
deleted file mode 100644
index f28b269..0000000
--- a/openwrt/package/serdisplib/Makefile
+++ /dev/null
@@ -1,82 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=serdisplib
-PKG_VERSION:=1.96
-PKG_RELEASE:=1
-PKG_MD5SUM:=b074e02d8d63f34cba8ec45c23f63f78
-
-PKG_SOURCE_URL:=@SF/serdisplib
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,SERDISPLIB,serdisplib,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
- (cd $(PKG_BUILD_DIR); \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ac_cv_func_malloc_0_nonnull=yes \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- --with-gnu-ld \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) all
- touch $@
-
-$(IPKG_SERDISPLIB):
- install -d -m0755 $(IDIR_SERDISPLIB)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/libserdisp.so.* $(IDIR_SERDISPLIB)/usr/lib
- $(RSTRIP) $(IDIR_SERDISPLIB)
- $(IPKG_BUILD) $(IDIR_SERDISPLIB) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/libserdisp.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_BUILD_DIR)/include/serdisplib $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/libserdisp.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/libserdisp.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/serdisplib \
- $(STAGING_DIR)/usr/lib/libserdisp.{a,so*} \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
-
-mostlyclean:
- $(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/serdisplib/ipkg/serdisplib.control b/openwrt/package/serdisplib/ipkg/serdisplib.control
deleted file mode 100644
index 3fcddcc..0000000
--- a/openwrt/package/serdisplib/ipkg/serdisplib.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: serdisplib
-Priority: optional
-Section: libs
-Description: A library for controlling displays
diff --git a/openwrt/package/serdisplib/patches/100-io.patch b/openwrt/package/serdisplib/patches/100-io.patch
deleted file mode 100644
index 5b78e10..0000000
--- a/openwrt/package/serdisplib/patches/100-io.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -ru serdisplib-1.96.orig/src/serdisp_connect.c serdisplib-1.96/src/serdisp_connect.c
---- serdisplib-1.96.orig/src/serdisp_connect.c 2005-10-07 20:40:50.000000000 +0200
-+++ serdisplib-1.96/src/serdisp_connect.c 2005-12-12 18:48:58.000000000 +0200
-@@ -60,6 +60,7 @@
- /* directIO only with linux and i386 */
- #if defined(__linux__) && (defined(__i386__) || defined(__x86_64__))
- #define __sd_linux_use_directIO__ 1
-+ #include <sys/io.h>
- #endif
-
-
-@@ -67,7 +68,6 @@
- #if defined(__linux__)
- #include <linux/ppdev.h>
- #include <linux/parport.h>
-- #include <sys/io.h>
- #include <stdlib.h>
- #define OUTB(_d, _p) outb( (_d), (_p) )
- #define INB(_p) inb( (_p) )
diff --git a/openwrt/package/serdisplib/patches/101-test_shared.patch b/openwrt/package/serdisplib/patches/101-test_shared.patch
deleted file mode 100644
index af0cd5d..0000000
--- a/openwrt/package/serdisplib/patches/101-test_shared.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ru serdisplib-1.96.orig/src/Makefile.in serdisplib-1.96/src/Makefile.in
---- serdisplib-1.96.orig/src/Makefile.in 2005-10-19 01:12:42.000000000 +0200
-+++ serdisplib-1.96/src/Makefile.in 2005-12-12 19:18:12.000000000 +0200
-@@ -73,8 +73,8 @@
- $(CC) -fPIC -shared -o $(LIB_DIR)/$(LIB_SHARED) $(LIB_OBJECTS)
- cd $(LIB_DIR) && $(LN_S) -f $(LIB_SHARED) $(LIB_NAME).so
-
--testserdisp: $(LIB_DIR)/$(LIB_STATIC) $(OBJECTS)
-- $(CC) -o testserdisp $(OBJECTS) $(LIB_DIR)/$(LIB_STATIC)
-+testserdisp: $(LIB_DIR)/$(LIB_SHARED) $(OBJECTS)
-+ $(CC) -o testserdisp $(OBJECTS) $(LIB_DIR)/$(LIB_SHARED)
-
- clean:
- /bin/rm -f $(OBJECTS) $(LIB_OBJECTS) $(LIB_DIR)/*.a $(LIB_DIR)/*.so*