summaryrefslogtreecommitdiff
path: root/openwrt/package/siproxd
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/siproxd')
-rw-r--r--openwrt/package/siproxd/Config.in12
-rw-r--r--openwrt/package/siproxd/Makefile70
-rw-r--r--openwrt/package/siproxd/files/siproxd.init21
-rw-r--r--openwrt/package/siproxd/ipkg/siproxd.conffiles2
-rw-r--r--openwrt/package/siproxd/ipkg/siproxd.control5
5 files changed, 0 insertions, 110 deletions
diff --git a/openwrt/package/siproxd/Config.in b/openwrt/package/siproxd/Config.in
deleted file mode 100644
index 2d48bad..0000000
--- a/openwrt/package/siproxd/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_SIPROXD
- prompt "siproxd........................... SIP (Session Initiation Protocol) proxy"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBOSIP2
- help
- A SIP (Session Initiation Protocol) proxy
-
- http://siproxd.sourceforge.net/
-
- Depends: libosip2
-
diff --git a/openwrt/package/siproxd/Makefile b/openwrt/package/siproxd/Makefile
deleted file mode 100644
index 5b3e1a5..0000000
--- a/openwrt/package/siproxd/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=siproxd
-PKG_VERSION:=0.5.12
-PKG_RELEASE:=1
-PKG_MD5SUM:=2fa02bd6f83070593bfc2d383ce614fa
-
-PKG_SOURCE_URL:=@SF/siproxd
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,SIPROXD,siproxd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared \
- --disable-static \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_SIPROXD):
- install -d -m0755 $(IDIR_SIPROXD)/etc
- $(CP) $(PKG_INSTALL_DIR)/etc/siproxd.conf.example $(IDIR_SIPROXD)/etc/siproxd.conf
- $(CP) $(PKG_INSTALL_DIR)/etc/siproxd_passwd.cfg $(IDIR_SIPROXD)/etc/
- install -d -m0755 $(IDIR_SIPROXD)/etc/init.d
- install -m0755 files/siproxd.init $(IDIR_SIPROXD)/etc/init.d/siproxd
- install -d -m0755 $(IDIR_SIPROXD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/siproxd $(IDIR_SIPROXD)/usr/sbin/
- $(RSTRIP) $(IDIR_SIPROXD)
- $(IPKG_BUILD) $(IDIR_SIPROXD) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/siproxd/files/siproxd.init b/openwrt/package/siproxd/files/siproxd.init
deleted file mode 100644
index f8739d4..0000000
--- a/openwrt/package/siproxd/files/siproxd.init
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-BIN=siproxd
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- mkdir -p $RUN_D
- $BIN $OPTIONS
- ;;
- stop)
- [ -f $PID_F ] && kill $(cat $PID_F)
- ;;
- *)
- echo "usage: $0 (start|stop)"
- exit 1
-esac
-exit $?
diff --git a/openwrt/package/siproxd/ipkg/siproxd.conffiles b/openwrt/package/siproxd/ipkg/siproxd.conffiles
deleted file mode 100644
index abb4ba5..0000000
--- a/openwrt/package/siproxd/ipkg/siproxd.conffiles
+++ /dev/null
@@ -1,2 +0,0 @@
-/etc/siproxd.conf
-/etc/siproxd_passwd.cfg
diff --git a/openwrt/package/siproxd/ipkg/siproxd.control b/openwrt/package/siproxd/ipkg/siproxd.control
deleted file mode 100644
index 96f73e2..0000000
--- a/openwrt/package/siproxd/ipkg/siproxd.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: siproxd
-Priority: optional
-Section: net
-Description: a SIP (Session Initiation Protocol) proxy
-Depends: libosip2, libpthread