summaryrefslogtreecommitdiff
path: root/openwrt/package/socat
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/socat')
-rw-r--r--openwrt/package/socat/Config.in18
-rw-r--r--openwrt/package/socat/Makefile66
-rw-r--r--openwrt/package/socat/ipkg/socat.control11
-rw-r--r--openwrt/package/socat/patches/501-honor_ldflags.patch13
4 files changed, 0 insertions, 108 deletions
diff --git a/openwrt/package/socat/Config.in b/openwrt/package/socat/Config.in
deleted file mode 100644
index d66693d..0000000
--- a/openwrt/package/socat/Config.in
+++ /dev/null
@@ -1,18 +0,0 @@
-config BR2_PACKAGE_SOCAT
- prompt "socat............................. A multipurpose relay (SOcket CAT)"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBOPENSSL
- select BR2_PACKAGE_LIBPTHREAD
- help
- SoCat (for SOcket CAT) establishes two bidirectional byte streams and
- transfers data between them.
- Data channels may be files, pipes, devices (terminal or modem, etc.), or
- sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,
- logging and tracing, different modes for interprocess communication and
- many more options.
-
- http://www.dest-unreach.org/socat/
-
- Depends: openssl
-
diff --git a/openwrt/package/socat/Makefile b/openwrt/package/socat/Makefile
deleted file mode 100644
index 034a618..0000000
--- a/openwrt/package/socat/Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=socat
-PKG_VERSION:=1.4.3.0
-PKG_RELEASE:=1
-PKG_MD5SUM:=ce574e75c2fda4456e8efd4efb86ec5e
-
-PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,SOCAT,socat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- sc_cv_termios_ispeed="no" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --disable-libwrap \
- --disable-readline \
- )
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_SOCAT):
- install -d -m0755 $(IDIR_SOCAT)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/socat $(IDIR_SOCAT)/usr/bin/
- $(RSTRIP) $(IDIR_SOCAT)
- $(IPKG_BUILD) $(IDIR_SOCAT) $(PACKAGE_DIR)
-
diff --git a/openwrt/package/socat/ipkg/socat.control b/openwrt/package/socat/ipkg/socat.control
deleted file mode 100644
index 7c079a9..0000000
--- a/openwrt/package/socat/ipkg/socat.control
+++ /dev/null
@@ -1,11 +0,0 @@
-Package: socat
-Priority: optional
-Section: net
-Depends: libpthread, libopenssl
-Description: A multipurpose relay (SOcket CAT).
- SoCat (for SOcket CAT) establishes two bidirectional byte streams and
- transfers data between them.
- Data channels may be files, pipes, devices (terminal or modem, etc.), or
- sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,
- logging and tracing, different modes for interprocess communication and
- many more options.
diff --git a/openwrt/package/socat/patches/501-honor_ldflags.patch b/openwrt/package/socat/patches/501-honor_ldflags.patch
deleted file mode 100644
index a41a929..0000000
--- a/openwrt/package/socat/patches/501-honor_ldflags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ruN socat-1.4-old/Makefile.in socat-1.4-new/Makefile.in
---- socat-1.4-old/Makefile.in 2005-09-10 22:09:11.000000000 +0200
-+++ socat-1.4-new/Makefile.in 2005-10-08 17:12:45.000000000 +0200
-@@ -36,7 +36,8 @@
-
- #0 CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
- CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(CPPFLAGS)
--CLIBS = $(LIBS)
-+LDFLAGS = @LDFLAGS@
-+CLIBS = $(LDFLAGS) $(LIBS)
- #CLIBS = $(LIBS) -lm -lefence
- XIOSRCS = xioinitialize.c xiohelp.c xioparam.c xiodiag.c xioopen.c xioopts.c \
- xiosignal.c xiosigchld.c xioread.c xiowrite.c \