summaryrefslogtreecommitdiff
path: root/openwrt/package/tcpdump
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/tcpdump')
-rw-r--r--openwrt/package/tcpdump/Config.in10
-rw-r--r--openwrt/package/tcpdump/Makefile73
-rw-r--r--openwrt/package/tcpdump/ipkg/tcpdump.control5
-rw-r--r--openwrt/package/tcpdump/patches/remove-pcap-debug.patch24
4 files changed, 0 insertions, 112 deletions
diff --git a/openwrt/package/tcpdump/Config.in b/openwrt/package/tcpdump/Config.in
deleted file mode 100644
index 1e32c60..0000000
--- a/openwrt/package/tcpdump/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_TCPDUMP
- prompt "tcpdump........................... Network monitoring and data acquisition tool"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBPCAP
- help
- A tool for network monitoring and data acquisition.
-
- http://www.tcpdump.org/
-
diff --git a/openwrt/package/tcpdump/Makefile b/openwrt/package/tcpdump/Makefile
deleted file mode 100644
index b19c0ef..0000000
--- a/openwrt/package/tcpdump/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=tcpdump
-PKG_VERSION:=3.9.4
-PKG_RELEASE:=1
-PKG_MD5SUM:=4b64755bbc8ba1af49c747271a6df5b8
-
-PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
- http://ftp.gwdg.de/pub/misc/tcpdump/ \
- http://www.at.tcpdump.org/ \
- http://www.br.tcpdump.org/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,TCPDUMP,tcpdump,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ac_cv_linux_vers=2 \
- td_cv_buggygetaddrinfo="no" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared \
- --disable-static \
- --enable-ipv6 \
- --without-crypto \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CCOPT="$(TARGET_CFLAGS)" INCLS="-I. -I$(STAGING_DIR)/usr/include" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_TCPDUMP):
- install -m0755 -d $(IDIR_TCPDUMP)/usr/sbin
- install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/tcpdump $(IDIR_TCPDUMP)/usr/sbin/
- $(RSTRIP) $(IDIR_TCPDUMP)
- $(IPKG_BUILD) $(IDIR_TCPDUMP) $(PACKAGE_DIR)
diff --git a/openwrt/package/tcpdump/ipkg/tcpdump.control b/openwrt/package/tcpdump/ipkg/tcpdump.control
deleted file mode 100644
index ca36169..0000000
--- a/openwrt/package/tcpdump/ipkg/tcpdump.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: tcpdump
-Priority: optional
-Section: net
-Description: A tool for network monitoring and data acquisition.
-Depends: libpcap
diff --git a/openwrt/package/tcpdump/patches/remove-pcap-debug.patch b/openwrt/package/tcpdump/patches/remove-pcap-debug.patch
deleted file mode 100644
index d8993f0..0000000
--- a/openwrt/package/tcpdump/patches/remove-pcap-debug.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urN tcpdump-3.9.4.orig/tcpdump.c tcpdump-3.9.4/tcpdump.c
---- tcpdump-3.9.4.orig/tcpdump.c 2005-08-23 12:29:41.000000000 +0200
-+++ tcpdump-3.9.4/tcpdump.c 2006-02-05 17:52:37.000000000 +0100
-@@ -762,20 +762,6 @@
- error("invalid data link type %s", gndo->ndo_dltname);
- break;
-
--#if defined(HAVE_PCAP_DEBUG) || defined(HAVE_YYDEBUG)
-- case 'Y':
-- {
-- /* Undocumented flag */
--#ifdef HAVE_PCAP_DEBUG
-- extern int pcap_debug;
-- pcap_debug = 1;
--#else
-- extern int yydebug;
-- yydebug = 1;
--#endif
-- }
-- break;
--#endif
- case 'Z':
- if (optarg) {
- username = strdup(optarg);