summaryrefslogtreecommitdiff
path: root/openwrt/package/uclibc++
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/uclibc++')
-rw-r--r--openwrt/package/uclibc++/Config.in7
-rw-r--r--openwrt/package/uclibc++/Makefile62
-rw-r--r--openwrt/package/uclibc++/files/config.i38676
-rw-r--r--openwrt/package/uclibc++/files/config.mips69
-rw-r--r--openwrt/package/uclibc++/ipkg/uclibc++.control4
-rw-r--r--openwrt/package/uclibc++/patches/cross-compile.patch14
6 files changed, 0 insertions, 232 deletions
diff --git a/openwrt/package/uclibc++/Config.in b/openwrt/package/uclibc++/Config.in
deleted file mode 100644
index 48c5b6b..0000000
--- a/openwrt/package/uclibc++/Config.in
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_UCLIBCXX
- prompt "uClibc++.......................... C++ library for embedded systems"
- tristate
- default m if CONFIG_DEVEL
- help
- A standard C++ library for embedded systems
-
diff --git a/openwrt/package/uclibc++/Makefile b/openwrt/package/uclibc++/Makefile
deleted file mode 100644
index bb08547..0000000
--- a/openwrt/package/uclibc++/Makefile
+++ /dev/null
@@ -1,62 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=uClibc++
-PKG_VERSION:=0.1.11
-PKG_RELEASE:=1
-PKG_MD5SUM:=8a8e0ee8fefef150c08a649fd7da04aa
-
-PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tbz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,UCLIBCXX,uclibc++,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
- -e 's/i.86/i386/' \
- -e 's/sparc.*/sparc/' \
- -e 's/arm.*/arm/g' \
- -e 's/m68k.*/m68k/' \
- -e 's/ppc/powerpc/g' \
- -e 's/v850.*/v850/g' \
- -e 's/sh64/sh/' \
- -e 's/sh[234].*/sh/' \
- -e 's/mips.*/mips/' \
- -e 's/mipsel.*/mips/' \
- -e 's/cris.*/cris/' \
-)
-
-$(PKG_BUILD_DIR)/.configured:
- $(CP) ./files/config.$(UCLIBC_TARGET_ARCH) $(PKG_BUILD_DIR)/.config
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- TOPDIR="$(PKG_BUILD_DIR)/" \
- $(TARGET_CONFIGURE_OPTS) \
- ARCH_CFLAGS="$(TARGET_CFLAGS)" \
- CROSS="$(TARGET_CROSS)" \
- all
- touch $@
-
-$(IPKG_UCLIBCXX):
- install -d -m0755 $(IDIR_UCLIBCXX)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so* $(IDIR_UCLIBCXX)/usr/lib/
- $(STRIP) $(IDIR_UCLIBCXX)/usr/lib/*.so*
- mkdir -p $(PACKAGE_DIR)
- $(IPKG_BUILD) $(IDIR_UCLIBCXX) $(PACKAGE_DIR)
-
-compile-targets: install-dev
-install-dev: $(PKG_BUILD_DIR)/.built
- $(MAKE) -C $(PKG_BUILD_DIR) \
- TOPDIR="$(PKG_BUILD_DIR)/" \
- $(TARGET_CONFIGURE_OPTS) \
- ARCH_CFLAGS="$(TARGET_CFLAGS)" \
- CROSS="$(TARGET_CROSS)" \
- DESTDIR="$(STAGING_DIR)" \
- install
diff --git a/openwrt/package/uclibc++/files/config.i386 b/openwrt/package/uclibc++/files/config.i386
deleted file mode 100644
index 4db0e36..0000000
--- a/openwrt/package/uclibc++/files/config.i386
+++ /dev/null
@@ -1,76 +0,0 @@
-#
-# Automatically generated make config: don't edit
-#
-# TARGET_arm is not set
-TARGET_i386=y
-# TARGET_mips is not set
-# TARGET_powerpc is not set
-
-#
-# Target Architecture Features and Options
-#
-HAVE_ELF=y
-TARGET_ARCH="i386"
-# CONFIG_GENERIC_386 is not set
-# CONFIG_386 is not set
-CONFIG_486=y
-# CONFIG_586 is not set
-# CONFIG_586MMX is not set
-# CONFIG_686 is not set
-# CONFIG_PENTIUMIII is not set
-# CONFIG_PENTIUM4 is not set
-# CONFIG_K6 is not set
-# CONFIG_K7 is not set
-# CONFIG_CRUSOE is not set
-# CONFIG_WINCHIPC6 is not set
-# CONFIG_WINCHIP2 is not set
-# CONFIG_CYRIXIII is not set
-ARCH_LITTLE_ENDIAN=y
-# ARCH_BIG_ENDIAN is not set
-UCLIBCXX_HAS_FLOATS=y
-WARNINGS="-Wall"
-HAVE_DOT_CONFIG=y
-
-#
-# String and I/O Stream Support
-#
-UCLIBCXX_HAS_WCHAR=y
-UCLIBCXX_IOSTREAM_BUFSIZE=32
-UCLIBCXX_HAS_LFS=y
-UCLIBCXX_SUPPORT_CDIR=y
-UCLIBCXX_SUPPORT_CIN=y
-UCLIBCXX_SUPPORT_COUT=y
-UCLIBCXX_SUPPORT_CERR=y
-# UCLIBCXX_SUPPORT_CLOG is not set
-# UCLIBCXX_SUPPORT_WCIN is not set
-# UCLIBCXX_SUPPORT_WCOUT is not set
-# UCLIBCXX_SUPPORT_WCERR is not set
-# UCLIBCXX_SUPPORT_WCLOG is not set
-
-#
-# STL and Code Expansion
-#
-UCLIBCXX_STL_BUFFER_SIZE=32
-UCLIBCXX_CODE_EXPANSION=y
-# UCLIBCXX_EXPAND_CONSTRUCTORS_DESTRUCTORS is not set
-UCLIBCXX_EXPAND_STRING_CHAR=y
-UCLIBCXX_EXPAND_VECTOR_BASIC=y
-# UCLIBCXX_EXPAND_IOS_CHAR is not set
-# UCLIBCXX_EXPAND_STREAMBUF_CHAR is not set
-UCLIBCXX_EXPAND_ISTREAM_CHAR=y
-UCLIBCXX_EXPAND_OSTREAM_CHAR=y
-UCLIBCXX_EXPAND_FSTREAM_CHAR=y
-# UCLIBCXX_EXPAND_SSTREAM_CHAR is not set
-
-#
-# Library Installation Options
-#
-UCLIBCXX_RUNTIME_PREFIX=""
-UCLIBCXX_RUNTIME_INCLUDE_SUBDIR="/include"
-UCLIBCXX_RUNTIME_LIB_SUBDIR="/lib"
-UCLIBCXX_RUNTIME_BIN_SUBDIR="/bin"
-UCLIBCXX_EXCEPTION_SUPPORT=y
-IMPORT_LIBSUP=y
-# IMPORT_LIBGCC_EH is not set
-# BUILD_STATIC_LIB is not set
-# DODEBUG is not set
diff --git a/openwrt/package/uclibc++/files/config.mips b/openwrt/package/uclibc++/files/config.mips
deleted file mode 100644
index cc9eb49..0000000
--- a/openwrt/package/uclibc++/files/config.mips
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-# Automatically generated make config: don't edit
-#
-# TARGET_arm is not set
-# TARGET_i386 is not set
-TARGET_mips=y
-# TARGET_powerpc is not set
-
-#
-# Target Architecture Features and Options
-#
-HAVE_ELF=y
-TARGET_ARCH="mips"
-ARCH_CFLAGS="-mno-split-addresses"
-# CONFIG_MIPS_ISA_1 is not set
-# CONFIG_MIPS_ISA_2 is not set
-# CONFIG_MIPS_ISA_3 is not set
-# CONFIG_MIPS_ISA_4 is not set
-CONFIG_MIPS_ISA_MIPS32=y
-# CONFIG_MIPS_ISA_MIPS64 is not set
-ARCH_LITTLE_ENDIAN=y
-# ARCH_BIG_ENDIAN is not set
-UCLIBCXX_HAS_FLOATS=y
-WARNINGS="-Wall"
-HAVE_DOT_CONFIG=y
-
-#
-# String and I/O Stream Support
-#
-UCLIBCXX_HAS_WCHAR=y
-UCLIBCXX_IOSTREAM_BUFSIZE=32
-UCLIBCXX_HAS_LFS=y
-UCLIBCXX_SUPPORT_CDIR=y
-UCLIBCXX_SUPPORT_CIN=y
-UCLIBCXX_SUPPORT_COUT=y
-UCLIBCXX_SUPPORT_CERR=y
-# UCLIBCXX_SUPPORT_CLOG is not set
-# UCLIBCXX_SUPPORT_WCIN is not set
-# UCLIBCXX_SUPPORT_WCOUT is not set
-# UCLIBCXX_SUPPORT_WCERR is not set
-# UCLIBCXX_SUPPORT_WCLOG is not set
-
-#
-# STL and Code Expansion
-#
-UCLIBCXX_STL_BUFFER_SIZE=32
-UCLIBCXX_CODE_EXPANSION=y
-# UCLIBCXX_EXPAND_CONSTRUCTORS_DESTRUCTORS is not set
-UCLIBCXX_EXPAND_STRING_CHAR=y
-UCLIBCXX_EXPAND_VECTOR_BASIC=y
-# UCLIBCXX_EXPAND_IOS_CHAR is not set
-# UCLIBCXX_EXPAND_STREAMBUF_CHAR is not set
-UCLIBCXX_EXPAND_ISTREAM_CHAR=y
-UCLIBCXX_EXPAND_OSTREAM_CHAR=y
-UCLIBCXX_EXPAND_FSTREAM_CHAR=y
-# UCLIBCXX_EXPAND_SSTREAM_CHAR is not set
-
-#
-# Library Installation Options
-#
-UCLIBCXX_RUNTIME_PREFIX=""
-UCLIBCXX_RUNTIME_INCLUDE_SUBDIR="/include"
-UCLIBCXX_RUNTIME_LIB_SUBDIR="/lib"
-UCLIBCXX_RUNTIME_BIN_SUBDIR="/bin"
-UCLIBCXX_EXCEPTION_SUPPORT=y
-IMPORT_LIBSUP=y
-# IMPORT_LIBGCC_EH is not set
-# BUILD_STATIC_LIB is not set
-# DODEBUG is not set
diff --git a/openwrt/package/uclibc++/ipkg/uclibc++.control b/openwrt/package/uclibc++/ipkg/uclibc++.control
deleted file mode 100644
index 5919e20..0000000
--- a/openwrt/package/uclibc++/ipkg/uclibc++.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: uclibc++
-Priority: optional
-Section: libs
-Description: A standard c++ library for embedded systems
diff --git a/openwrt/package/uclibc++/patches/cross-compile.patch b/openwrt/package/uclibc++/patches/cross-compile.patch
deleted file mode 100644
index bd14950..0000000
--- a/openwrt/package/uclibc++/patches/cross-compile.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN uClibc++.old/extra/Configs/Config.in uClibc++.dev/extra/Configs/Config.in
---- uClibc++.old/extra/Configs/Config.in 2005-01-14 22:47:46.000000000 +0100
-+++ uClibc++.dev/extra/Configs/Config.in 2005-04-25 21:12:01.000000000 +0200
-@@ -38,8 +38,8 @@
- #config TARGET_microblaze
- # bool "microblaze"
-
--#config TARGET_mips
--# bool "mips"
-+config TARGET_mips
-+ bool "mips"
-
- config TARGET_powerpc
- bool "powerpc"