summaryrefslogtreecommitdiff
path: root/openwrt/package/udp-broadcast-relay
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/udp-broadcast-relay')
-rw-r--r--openwrt/package/udp-broadcast-relay/Config.in12
-rw-r--r--openwrt/package/udp-broadcast-relay/Makefile35
-rw-r--r--openwrt/package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control4
3 files changed, 0 insertions, 51 deletions
diff --git a/openwrt/package/udp-broadcast-relay/Config.in b/openwrt/package/udp-broadcast-relay/Config.in
deleted file mode 100644
index da3c224..0000000
--- a/openwrt/package/udp-broadcast-relay/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config BR2_PACKAGE_UDP_BROADCAST_RELAY
- prompt "udp-broadcast-relay............... listens for packets on a specified UDP broadcast port."
- tristate
- default m if CONFIG_DEVEL
- help
- This program listens for packets on a specified UDP broadcast port. When a packet is received, it sends that packet to all specified interfaces but the one it came from as though it originated from the original sender.
-
- The primary purpose of this is to allow games on machines on separated local networks (Ethernet, WLAN) that use udp broadcasts to find each other to do so.
-
- It also works on ppp links, so you can log in from windows boxes (e.g. using pptp) and play LAN-based games together. Currently, you have to care about upcoming or downgoing interfaces yourself.
-
- http://www.joachim-breitner.de/udp-broadcast-relay/
diff --git a/openwrt/package/udp-broadcast-relay/Makefile b/openwrt/package/udp-broadcast-relay/Makefile
deleted file mode 100644
index e96d1d2..0000000
--- a/openwrt/package/udp-broadcast-relay/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=udp-broadcast-relay
-PKG_VERSION:=0.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=a32f983b7063d6ac670e6b22be9b9d24
-
-PKG_SOURCE_URL:=http://www.joachim-breitner.de/udp-broadcast-relay/files/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,UDP_BROADCAST_RELAY,udp-broadcast-relay,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
- touch $@
-
-$(IPKG_UDP_BROADCAST_RELAY):
- mkdir -p $(IDIR_UDP_BROADCAST_RELAY)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_UDP_BROADCAST_RELAY)/usr/sbin/
- $(STRIP) $(IDIR_UDP_BROADCAST_RELAY)/usr/sbin/*
- $(IPKG_BUILD) $(IDIR_UDP_BROADCAST_RELAY) $(PACKAGE_DIR)
-
-mostlyclean:
- $(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control b/openwrt/package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control
deleted file mode 100644
index f83247a..0000000
--- a/openwrt/package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: udp-broadcast-relay
-Priority: optional
-Section: net
-Description: This program listens for packets on a specified UDP broadcast port. When a packet is received, it sends that packet to all specified interfaces but the one it came from as though it originated from the original sender.