summaryrefslogtreecommitdiff
path: root/openwrt/package/vncrepeater
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/vncrepeater')
-rw-r--r--openwrt/package/vncrepeater/Config.in17
-rw-r--r--openwrt/package/vncrepeater/Makefile42
-rw-r--r--openwrt/package/vncrepeater/ipkg/vncrepeater.control5
-rw-r--r--openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch32
4 files changed, 0 insertions, 96 deletions
diff --git a/openwrt/package/vncrepeater/Config.in b/openwrt/package/vncrepeater/Config.in
deleted file mode 100644
index 418f485..0000000
--- a/openwrt/package/vncrepeater/Config.in
+++ /dev/null
@@ -1,17 +0,0 @@
-config BR2_PACKAGE_VNCREPEATER
- prompt "vncrepeater....................... UltraVNC repeater for Linux"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_UCLIBCXX
- help
- Viewer can be behind Nat router or directly connected to the internet
-
- Instead of forwarding serveral ports, you only need to forward 1 port
-
- If the PC that runs the Repeater has access to the local DNS server,
- you can use your local DNS names instead of 10.10.10.12.
-
- This could be handy when you have a dynamic DHCP server allocating
- ip adresses for your PC.
-
- http://ultravnc.sourceforge.net/addons/repeater.html
diff --git a/openwrt/package/vncrepeater/Makefile b/openwrt/package/vncrepeater/Makefile
deleted file mode 100644
index 2d1d450..0000000
--- a/openwrt/package/vncrepeater/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vncrepeater
-PKG_VERSION:=0.12
-PKG_RELEASE:=1
-PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
-
-PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,VNCREPEATER,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) \
- CFLAGS="$(TARGET_CFLAGS)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- repeater
- touch $@
-
-$(IPKG_VNCREPEATER):
- install -d -m0755 $(IDIR_VNCREPEATER)/usr/sbin $(IDIR_VNCREPEATER)/etc
- $(CP) $(PKG_BUILD_DIR)/repeater $(IDIR_VNCREPEATER)/usr/sbin/$(PKG_NAME)
- install -d -m0755 $(IDIR_VNCREPEATER)/etc
- $(CP) $(PKG_BUILD_DIR)/uvncrepeater.ini $(IDIR_VNCREPEATER)/etc/vncrepeater.conf
- install -d -m0755 $(IDIR_VNCREPEATER)/etc/init.d
- $(CP) $(PKG_BUILD_DIR)/S60vncrepeater $(IDIR_VNCREPEATER)/etc/init.d/
- $(RSTRIP) $(IDIR_VNCREPEATER)
- $(IPKG_BUILD) $(IDIR_VNCREPEATER) $(PACKAGE_DIR)
diff --git a/openwrt/package/vncrepeater/ipkg/vncrepeater.control b/openwrt/package/vncrepeater/ipkg/vncrepeater.control
deleted file mode 100644
index 3996c86..0000000
--- a/openwrt/package/vncrepeater/ipkg/vncrepeater.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: vncrepeater
-Section: net
-Depends: uclibc++
-Priority: optional
-Description: UltraVNC repeater for Linux
diff --git a/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch b/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch
deleted file mode 100644
index 06020ee..0000000
--- a/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -urN vncrepeater-0.12/Makefile vncrepeater-0.12.new/Makefile
---- vncrepeater-0.12/Makefile 2006-03-31 07:40:14.000000000 +0200
-+++ vncrepeater-0.12.new/Makefile 2006-04-11 10:26:06.345879104 +0200
-@@ -1,21 +1,21 @@
--CFLAGS=-Wall
-+CFLAGS=-Wall
- repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
-- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
-+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
-
- repeater.o: repeater.cpp
-- g++ $(CFLAGS) -c repeater.cpp
-+ $(CC) $(CFLAGS) -c repeater.cpp
-
- repeaterproc.o: repeaterproc.cpp
-- g++ $(CFLAGS) -c repeaterproc.cpp
-+ $(CC) $(CFLAGS) -c repeaterproc.cpp
-
- openbsd_stringfuncs.o: openbsd_stringfuncs.cpp
-- g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
-+ $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
-
- iniparser.o: iniparser.cpp
-- g++ $(CFLAGS) -c iniparser.cpp
-+ $(CC) $(CFLAGS) -c iniparser.cpp
-
- readini.o: readini.cpp
-- g++ $(CFLAGS) -c readini.cpp
-+ $(CC) $(CFLAGS) -c readini.cpp
-
- clean:
- rm -f *.o repeater