summaryrefslogtreecommitdiff
path: root/openwrt/package/wpa_supplicant
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/wpa_supplicant')
-rw-r--r--openwrt/package/wpa_supplicant/Config.in16
-rw-r--r--openwrt/package/wpa_supplicant/Makefile40
-rw-r--r--openwrt/package/wpa_supplicant/files/config17
-rw-r--r--openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control5
-rw-r--r--openwrt/package/wpa_supplicant/patches/101-ldflags.patch24
-rw-r--r--openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch12
6 files changed, 0 insertions, 114 deletions
diff --git a/openwrt/package/wpa_supplicant/Config.in b/openwrt/package/wpa_supplicant/Config.in
deleted file mode 100644
index bac4e46..0000000
--- a/openwrt/package/wpa_supplicant/Config.in
+++ /dev/null
@@ -1,16 +0,0 @@
-config BR2_PACKAGE_WPA_SUPPLICANT
- prompt "wpa_supplicant.................... WPA Supplicant with support for WPA and WPA2"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_KMOD_MADWIFI
- select BR2_PACKAGE_LIBOPENSSL
- help
- WPA Supplicant with support for WPA and WPA2 (IEEE 802.11i / RSN).
- Supplicant is the IEEE 802.1X/WPA component that is used in the client
- stations. It implements key negotiation with a WPA Authenticator and it
- controls the roaming and IEEE 802.11 authentication/association.
-
- http://hostap.epitest.fi/wpa_supplicant/
-
- Depends: openssl
-
diff --git a/openwrt/package/wpa_supplicant/Makefile b/openwrt/package/wpa_supplicant/Makefile
deleted file mode 100644
index 44276969..0000000
--- a/openwrt/package/wpa_supplicant/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.4.9
-PKG_RELEASE:=1
-PKG_MD5SUM:=98498c152cbfc388c306fd9bbf7d57d4
-
-PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,WPA_SUPPLICANT,wpa-supplicant,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- $(CP) ./files/config $(PKG_BUILD_DIR)/.config
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/madwifi" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- OPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL=$(LINUX_DIR) \
- all
- touch $@
-
-$(IPKG_WPA_SUPPLICANT):
- install -m0755 -d $(IDIR_WPA_SUPPLICANT)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/wpa_cli $(IDIR_WPA_SUPPLICANT)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/wpa_passphrase $(IDIR_WPA_SUPPLICANT)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/wpa_supplicant $(IDIR_WPA_SUPPLICANT)/usr/sbin/
- $(RSTRIP) $(IDIR_WPA_SUPPLICANT)
- $(IPKG_BUILD) $(IDIR_WPA_SUPPLICANT) $(PACKAGE_DIR)
diff --git a/openwrt/package/wpa_supplicant/files/config b/openwrt/package/wpa_supplicant/files/config
deleted file mode 100644
index 19a0fd3..0000000
--- a/openwrt/package/wpa_supplicant/files/config
+++ /dev/null
@@ -1,17 +0,0 @@
-# rather important
-CONFIG_DRIVER_BROADCOM=y
-CONFIG_DRIVER_HOSTAP=y
-CONFIG_DRIVER_MADWIFI=y
-CONFIG_DRIVER_WEXT=y
-CONFIG_IEEE8021X_EAPOL=y
-CONFIG_CTRL_IFACE=y
-
-# default
-CONFIG_EAP_PSK=y
-CONFIG_EAP_MD5=y
-
-# optional
-CONFIG_MSCHAPV2=y
-CONFIG_EAP_TLS=y
-CONFIG_EAP_PEAP=y
-CONFIG_EAP_TTLS=y
diff --git a/openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control b/openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control
deleted file mode 100644
index ea4f7f8..0000000
--- a/openwrt/package/wpa_supplicant/ipkg/wpa-supplicant.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: wpa-supplicant
-Priority: optional
-Section: net
-Description: WPA Supplicant with support for WPA and WPA2
-Depends: libopenssl
diff --git a/openwrt/package/wpa_supplicant/patches/101-ldflags.patch b/openwrt/package/wpa_supplicant/patches/101-ldflags.patch
deleted file mode 100644
index b8b6f66..0000000
--- a/openwrt/package/wpa_supplicant/patches/101-ldflags.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- wpa_supplicant-0.3.8/Makefile.orig 2005-05-22 12:37:28.000000000 +0200
-+++ wpa_supplicant-0.3.8/Makefile 2005-05-22 12:40:04.000000000 +0200
-@@ -304,7 +304,7 @@
- OBJS += wpa_supplicant.o wpa.o l2_packet.o drivers.o
-
- wpa_supplicant: .config $(OBJS)
-- $(CC) -o wpa_supplicant $(OBJS) $(LIBS)
-+ $(CC) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS)
-
- eapol_test: .config $(OBJS_t)
- $(CC) -o eapol_test $(OBJS_t) $(LIBS)
-@@ -313,10 +313,10 @@
- $(CC) -o preauth_test $(OBJS_t2) $(LIBS)
-
- wpa_passphrase: $(OBJS_p)
-- $(CC) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
-+ $(CC) $(LDFLAGS) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
-
- wpa_cli: $(OBJS_c)
-- $(CC) -o wpa_cli $(OBJS_c) $(LIBS_c)
-+ $(CC) $(LDFLAGS) -o wpa_cli $(OBJS_c) $(LIBS_c)
-
- win_if_list: win_if_list.c
- $(CC) -o $@ win_if_list.c $(CFLAGS) $(LIBS_w)
diff --git a/openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch b/openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch
deleted file mode 100644
index ec38b73..0000000
--- a/openwrt/package/wpa_supplicant/patches/102-opt_cflags.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- wpa_supplicant-0.3.8/Makefile.orig 2005-02-14 02:55:47.000000000 +0100
-+++ wpa_supplicant-0.3.8/Makefile 2005-05-21 21:06:03.000000000 +0200
-@@ -3,7 +3,8 @@
- endif
-
- ifndef CFLAGS
--CFLAGS = -MMD -O2 -Wall -g
-+OPT_FLAGS = -O2 -g
-+CFLAGS = -MMD $(OPT_FLAGS) -Wall
- endif
-
- # Include directories for CVS version